Starting games with play button

Lutris is really great but in all the short time I have used it I have never been able to launch wine games using the “Play Game” button. I always have to use “Run EXE in wine prefix”. This is really causing me problems when I need to use command line arguments. Is this a normal problem? I had similar issues with POL but it did work some of the time. Also how does the dxvk option work? I was never able to get dxvk to work in POL but when I do the same thing in Lutris with the dxvk option enabled it magically works, and will the dxvk version list be updated soon?

I think that it would be more helpful for others if you run Lutris from the Terminal (open it and type lutris), then press the play button and see if it throws any errors or warnings, and posting the Terminal output here I think it would be a good ideea.

Also I think that no one can help you if you don’t give any informations about what Distro you have, what wine version, what architecture (32 bit or 64 bit)

As for DXVK, it is a separate project from Lutris and the list of games running with DXVK is updated constantly as the project grows, or when someone discovers how to make certain games work with it, on Lutris the game list is as well constantly updated as soon as someone posts a new and working installation script

I was just asking with no details first since it could be a common problem. I am on Linux Mint Cinnamon 18.3 64-bit. I use Nvidia for graphics and I install Lutris with the Linux Mint package manager. I also use lates non PBA staging. I will post the terminal output below but looking at it it could be something simple. I did check though and in the system settings the Lutris runtime is not disabled. Also when I asked about dxvk I was talking about how in the runner options you can enable dxvk and select a version. I was asking when will that list of versions be updated.

WARNING 2018-06-14 09:11:31,467 [application]:This version of Gtk doesn’t support set_option_context_summary
INFO 2018-06-14 09:11:32,814 [lutriswindow]:Connected to as Singest
INFO 2018-06-14 09:11:50,587 [runner]:Runtime disabled by system configuration
INFO 2018-06-14 09:11:50,918 [runner]:Runtime disabled by system configuration
ERROR 2018-06-14 09:11:50,922 [thread]:Failed to execute Xephyr :2 -ac -screen 640x480x16 -glamor -reset -terminate -fullscreen: [Errno 2] No such file or directory: ‘Xephyr’
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/”, line 191, in execute_process
cwd=self.cwd, env=env)
File “/usr/lib/python3.5/”, line 947, in init
restore_signals, start_new_session)
File “/usr/lib/python3.5/”, line 1551, in _execute_child
raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: ‘Xephyr’
WARNING 2018-06-14 09:11:50,944 [thread]:No game process available
INFO 2018-06-14 09:12:07,928 [runner]:Runtime disabled by system configuration
INFO 2018-06-14 09:43:02,016 [application]:Shutting down Lutris

Update before I finished writing the post is that I got it working.

what is going here? why are you launching Xephyr?

I had just made the prefix but somehow that and all my other applications had their system settings completely different from my defaults. They had the Lutris Runtime disabled and Xephyr enabled. I also did not have Xephyr installed. I just checked and my default system settings are being overridden by my wine system settings which somehow got set to all the stuff describe above. Hopefully this is enough to explain everything. One thing that is a little strange is that I have had this problem with all my installations of Lutris including one that was on a flash drive I think. I should have investigated more before posting. I just assumed it was a normal problem like what I had been used to in POL.

I should still make a fix so that Lutris doesn’t crash like that when Xephyr isn’t installed

I launched a couple of games after removing xephyr and enabling it, but I couldnt reproduce lutris crash.
Arch lutris 0.4.18 python 3.6

Lutris Runtime was also disabled.

The next release will now show an error message when Xephyr isn’t installed but is used.