Back to the main site

StarCraft II Zoomed on Ultrawide Display

My best friend recently upgraded to a 4K display and gave me his ~3-year-old ultrawide 2560x1080 monitor. When I try to play StarCraft II on it, the game is zoomed in on the upper-left. I’d set the resolution in the game’s video settings, but I can’t do that because I can’t access that part of the settings window. What can I do? Is there a command-line option I can use in the Battle.net launcher? Or at least, why doesn’t Alt-Enter work for putting the game in windowed mode and what can I use instead?

Please let us know what distro/desktop environment you are using as well system specs.
For example I’ve had issues with hidpi under gnome and mate causing a similar issue to the one you are describing.
Have you tried enabling virtual desktop under runner options?

I’m running Debian Bullseye with XFCE 4.14.

System Specs:
Dell Optiplex 3020
Intel i3-4130
Nvidia GT 1030
8 GB 1600 MHz DDR3
LG 29UM58 2560 x 1080 monitor

Also, I tried virtual desktop, but it didn’t work. Strangely enough, StarCraft Remastered picks up on the resolution without issue, and StarCraft II is the only one to have this issue.

Update: I did some rearch and found the command line option for starting the game in windowed mode (-Displaymode 0) and put that into the Extra Command Line Options section in the Battle.net app. After that, Starcraft II started up in Windowed mode. The window was small, so I maximized it, which, while stretching the interface, made it easier to navigate. Once I did that, I was finally able to set the resolution. Unfortunately, it doesn’t have an option for 2560x1080; it only goes as high as 1920x1080 - perhaps to deliberately exclude ultrawide monitors. After I set the resolution to 1080p, it didn’t quite look right. I fiddled with my monitor and I discovered that it has different picture mode options. They’re named a little strangely (i.e. ultrawide mode called Original), but at least I’ve found a workable solution.

Can you confirm which version of wine you are using and which script uou are using (dxvk/d9vk or opengl)?
I haven’t played on an ultrawide in a while, so I’ll test again when I get home.