Starcraft II with d9vk

I noticed that there is an installer for Starcraft II that uses d9vk.

After using this new installer, I installed SC2 and ran it. However, the NVidia HUD is showing it as running in OpenGL still. Since this is new I have no idea where to start with this.

I noticed in the logs that it was replacing DLLs like it should but only for DX10 and 11. Should it be replacing DX9 Dlls as well?

INFO     2019-05-09 20:03:56,232 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/system32/dxgi with DXVK version
INFO     2019-05-09 20:03:56,233 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/system32/d3d11 with DXVK version
INFO     2019-05-09 20:03:56,234 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/system32/d3d10core with DXVK version
INFO     2019-05-09 20:03:56,235 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/system32/d3d10_1 with DXVK version
INFO     2019-05-09 20:03:56,236 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/system32/d3d10 with DXVK version
INFO     2019-05-09 20:03:56,237 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/syswow64/dxgi with DXVK version
INFO     2019-05-09 20:03:56,239 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/syswow64/d3d11 with DXVK version
INFO     2019-05-09 20:03:56,240 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/syswow64/d3d10core with DXVK version
INFO     2019-05-09 20:03:56,242 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/syswow64/d3d10_1 with DXVK version
INFO     2019-05-09 20:03:56,242 [dxvk.enable_dxvk_dll:123]:Replacing /home/james/Games/starcraft-ii/drive_c/windows/syswow64/d3d10 with DXVK version

DEBUG    2019-05-09 20:03:56,299 [command.start:107]:ENV: WINEDLLOVERRIDES=“d3d10,d3d10_1,d3d10core,d3d11,dxgi=n;d3d12,nvapi,nvapi64=”

It seems like dxvk is activated but not d9vk.Have you tried manually adding d9vk like in this video ?
It looks like you need to make d9vk folder and extract the zip from this website to it.
And select d9vk from lutris runner options.

Thanks for the reply. I checked earlier if that had installed correctly and it had. The folder was where it should be and the correct version of d9vk was references. I believe if that had been incorrect, then DXKV wouldn’t have loaded at all.

I figured it out. I was on version 0.5.1 and needed to be on 0.5.2 for this to work.