Back to the main site

Starcraft 2 keep ignoring optimus setup

Hello,

First of all, please note that I checked the battle net wikipage, but so far, I have not been able to understand where my mistake was.

I recently got a new laptop 2nd hand with a geforce 920M card. I set up optimus on my laptop and both optirun and primusrun works in console as expected.

Now, I wanted to play starcraft, so I installed it and started to configure the game. I’m now able to run it, but despite the fact I selected discrete card and optimus launcher, it doesn’t seem to work as expected.

In the logs, I can see primusrun is used to launch battle net, no error detected. But when in the game, if I open the option, my card is identified as intel.

I tried to launch both battle.net launcher and starcraft2 exe, with the same result.
I also tried to launch starcraft 2 exe in the wine prefx(I found that tip online), so far no luck.

Would you have any tips for me ?
Is it possible that when battle net launch starcraft 2, it get out of the primusrun context, back to the usual one ?

If you have any other suggestion than optimus, I can also try to see what can be done. I didn’t choose nvidia-prime, but that could be another option to get it work maybe.

Regards,
Pierre

Hi,

After some research, I decided to give a go to nvidia-prime.
It looks much more promising.

Strangely, the video card is not named anymore in the option of starcraft 2, but it looks quite fast.

I’m going to play a bit with these information to tune them in a better way.