Back to the main site

Star Wars Battlefront II (2017) - Lutris

Hi

I’m trying to find a way to get the Star Wars Battlefront II (2017) version going on Lutris. I know the installer basically only installs Origin. I have seen and know that folks managed to get games with the likes of Anthem and Battlefield V going, but Battlefront II is still giving issues.

Is there anyone who may have some idea or indication as to what BFII is trying to use/launch in the background that prohibits it from starting up? I strongly suspect the issue is with a missing program or function but I’m just unsure as to how to identify it. I have tried installing and changing various Windows components (and also manged to break the Wine instance quite a few times in the process).

Here is small summary of what Ive tried the past few weeks:

  • Tried various Wine staging versions
  • Tried various DXVK versions and even disabling it
  • Hiding Wine version detection
  • Enable and disable Lutris run time components
  • Enable and disable “prefer system libraries”
  • With and without virtual desktop
  • Installed all DirectX 9, 10 and 11 components,
  • Installed Dot Net, Visual C++ all versions, even visual basic components
  • Installed all fonts

And many more that I can’t even recall at the moment. I have also tried different combinations of the above settings enabled/disabled.

Many thanks in advance.

I finally got this working. I am using Salient OS which is an offshoot of Arch. I am running a Nvidia 1060 with 6GB of memory. Nvidia driver 430.34 I am using wine staging 4.12.1. I am running DXVK 1.3.1 and in the runners options, I have this: Wine Version: System 4.12.1(Staging)), Enable DXVK. Everything else is stock settings, then in System options, I have: Preferred system libraries, enable Feral Gamemode and these are my keys:
DXVK_CONFIG_FILE /your path to where the game is installed/star-wars-battlefront-ii-2017/dxvk.conf

LF_PRELOAD /usr/lib/libgamemodeauto.so

DKVX_HUD 0

STAGING_SHARED_MEMORY 0

_GL_SHADER_DISK_CACHE_PATH /(path to where your game is installed/star-wars-battlefront-ii-2017/bfv-nv-shaders

exclude process QTWebEngineProcess.exe ActivationUI.exe OriginWebhelperServices.exe

Everything else is default. I hope this helps. You have to have gamemode installed which is available in the AUR for Arch users. You’ll have to search how to install if for Debian based distros. Google Chris Titus Gamemode in Youtube videos. He has a nice video on how to install and configure it.

Best of luck

Awesome, I will have to try this. Thank you for the feedback!

As luck would have it, I’m away on business now but I’m really keen to try when I get back.

1 Like

I managed to make the game to run by simply installing the default installer from Lutris, setting it to wine staging-4.14, and spoofing a nvidia video card to work around the driver version detection issue.

However it’s not in any state playable, I can get in a match just fine, but when it gets there it’s mayhem. It freezes for whole minutes, to unfreeze for 2 seconds and either freeze again or disconnect me to the menus.

I’m not sure if that happens due to shader caching, but I’ll keep trying to see if gets any better with time.