Star Trek Starfleet Command III - GOG Install

I installed Star Trek: Starfleet Command III from GOG. When I start it, the opening videos play and then it hangs. I get a pop-up saying: “Unable to get backbuffer desc”. I have to kill the process as the popup controls don’t respond.



I’ve pasted additional info here: Pastebin

Yup, seeing the same error. A shame, I was just trying to reinstall this last night. The worst thing is this previously worked 2 years ago, I even had it working as an install script for sometime. This makes me think that it might have something to do with the wine version.

Okay, some progress. SFC3 + Upgrade Mod 33 installs well in Bottles and does so with the latest GE wine. I’m drawing the cache error because d3dxof is not exposed as a dependency in Bottles, but I’m sure I could extract and override the dll in Bottles or roughly mirror the dependencies/components back to Lutris. I’ll report back when I have the time to try it out.

Okay, some more “progress.” Forget nearly everything in the previous reply. Installing with lutris, with a current wine, and d3dxof works fine. The backbuffer error appears to be coming from some interaction with DXVK. Disabling DXVK (probably be able to find an earlier version that won’t throw errors) gets us back to the main menu of SFC3. However, I’m now encountering the glow error as mentioned by @Michel86. So new breakage has settled back to old breakage. I suppose a potential remedy is sniffing out a SFC3 binary that doesn’t have the GOG patches applied to it.

Edit: Okay. Try this. It is installing for me correctly now. The ModelRendererR.dll that had been edited by GOG in their last few patches has reportedly caused the glow issue, which is now resolved by disabling that renderer (ModelRendererR.dll → ModelRendererR.dll.bak) and re-enabling the included older ModelRendererR.dll (ModelRendererR_old.dll → ModelRendererR.dll). I’ve chosen a dxvk version that won’t cause the backbuffer error (v1.10.3).

Help me test the installer script. If it works out for interested users, I’ll submit it

1 Like

I think I figured out how to install it with your GitHub script. Lutris has changed since the last time I messed with it.

Unfortunately, I don’t have a visible mouse cursor. I’ve tried a few different versions of wine with no luck. It’s difficult to test without a visible mouse.

Edit: I think the installation script did successfully complete. I’ve tried several wine versions, but I still have an invisible mouse. Any ideas?

I’ve tried a bunch of different wine and dxvk versions, but none displayed a mouse cursor.

The closest I think I got was using lutris-fshack-6.21-6-x86_64, which threw an Unhandled Exception Error. FYI, that version works on the CD version of the game with DXVK 2.3.

Which version of wine are you using?

@jrobio OK. I just reinstalled again using your Github installer and it works!

FYI, I figured out my invisible mouse cursor problem. I had used the wine configuration option to increase the dpi from 96 to 144 to make working on it more readable on my 2k monitor. It never caused a problem with the CD version, but it apparently causes problems with the GoG version.

Thanks for your installer!

1 Like

Glad to hear this worked out. I couldn’t begin to speculate why it would just start to randomly work, my last commit was yesterday before announcing on the thread. The wine version I am using is the latest GE release wine-ge-25-x86_64.

It actually makes sense the CD version is easier to get up and running, because as @Michel86 noted in the other thread:

GOG’s patches appear to have introduced regressions for linux users. Fortunately, I believe we are able to turn off much of their work by disabling their edited ModelRendererR.dll and re-enabling the older one. However, this might prove difficult for users with both AMD and RDNA hardware, but I’m just speculating. I believe we are also missing the glow effects, but at least the game works.

Regardless, I’m happy to hear this is working for you. I think my next goal is going to be some abandonware: orion pirates.

@jrobio I started a conquest campaign and noticed that several ships, such as the Federation Olympic, in the shipyard are invisible/not shown, but their components are. If I buy one of those ships, the game locks up. I’ve tested using both the “new” and “old” renderer. Do you see this?

I’m not sure if it’s a linux/lutris/wine/dxvk problem or a problem with the mod included in the Github installation script.

Edit: So far, the game has only locked up the first time I bought one of those ships. Must have been a glitch.

Yup, I’m seeing the missing art in the vessel library as well. This issue is mentioned two other places: here and here. One of those is related to a thread about the Upgrade Mod, so it is entirely possible there is a negative interaction there. I’ll do some testing in the next couple of days to see if I can clear it. However, I’ve played with a number of those ships and haven’t seen any lock-ups yet.

So, I haven’t been able to figure out the vessel library issue. The closest thing I’ve seen to a resolution is on the GOG forums where using Nvidia’s proprietary software clears it, but that won’t be available to linux users.

That said, I’ve gotten Orion Pirates working. It’s actually a far more stable experience because there is a larger community of folks still working on patches. Gameplay-wise, it’s a deeper strategy experience. Try out the installer and let me know if it works for you.