Star Trek Online (STO) does not start

I have just done a brand new install of Start Trek Online. The game installs quickly. However after hitting the “Play” button on the game from the Lutris main window for the first time it simple exits after a few seconds. Here are the logs:

Started initial process 1270 from gamemoderun /home/kemra102/.var/app/net.lutris.Lutris/data/lutris/runners/wine/lutris-7.2-2-x86_64/bin/wine /home/kemra102/Games/star-trek-online/drive_c/Star Trek Online.exe
Start monitoring process.
fsync: up and running.
Application could not be started, or no application associated with the specified file.
ShellExecuteEx failed: File not found.

Monitored process exited.
Initial process has exited (return code: 256)
Exit with return code 256

The Lutris page for STO says first start will take a while first time but it seems to just die instead right now. I cannot see any extra processes running on my system beyond the normal ones so it does appear to have properly exited.

It’s worth pointing out that the binary the error mentions is exactly where it says it’s looking so I’ve no idea why it doesn’t find it.

Is the exe actually located in the root of the virtual C drive?

Normally apps are installed in C:\Program Files… and not directly in the root.

Yep the .exe seems to be in the root of the C: drive

[kemra102@fedora drive_c]$ ll
total 4
drwxr-xr-x. 1 kemra102 kemra102   18 Apr 21 10:04  ProgramData
drwxr-xr-x. 1 kemra102 kemra102  118 Apr 21 10:04 'Program Files'
drwxr-xr-x. 1 kemra102 kemra102  118 Apr 21 10:04 'Program Files (x86)'
-rw-r--r--. 1 kemra102 kemra102 2999 Apr 21 10:04 'Star Trek Online.exe'
drwxr-xr-x. 1 kemra102 kemra102   28 Apr 21 10:04  users
drwxr-xr-x. 1 kemra102 kemra102  492 Apr 21 10:04  windows
[kemra102@fedora drive_c]$ pwd

Not sure if that’s normal for this game but it seems to be where it’s expected as far as I can tell.

The non-steam version downloads the file from the website. The thing is, they now use an installer file because the game is now maintained by arc games. It is called Star-trek-online_Arc2Setup.exe. That’s probably why it is not found. It will probably work when you change the exe in the game config to the new exe.

If the install succeeds then I expect that the exe config should be changed to the installed Star Trek Online.exe.

Needed a couple of things to get the game installed, firstly the download URL for the installer needed changing to:

Then the path for the installed game binary needs updating to drive_c/Program Files (x86)/Star Trek Online_en/Star Trek Online.exe.

Although I’ve got it installed OK I have a runtime problem now, every loading screen past character selection hangs indefinitely. You get the message about patching files which immediately drops to 0 bytes/s and the spinner freezes with everything else (though the music is not impacted).

I’m having similar problems as of 7/31/23 on a clean install of POP and Lutris and Wine (8.02). Same error, so the install scripts are still not right. I’m totally new to Lutris (like, hours!), so gotta figure out how to fix this…in theory could make your changes to install script and run that? but not sure how (yet!)

NW should be similar, so if I can figure this out maybe I can get 'em both working…

never got it to work under lutris/wine. Tried older versions, incl 7.2, no joy. Cryptic’s installer no-go, even t/ settings that worked under steam. I think the lutris wrapper/settings/config needs an eyeball from someone who knows more than me.
Got it running sorta-ok under proton, was able to avoid account linking to steam. Launching cryptic’s launcher as non-steam app w/ --disable-gpu and safe mode worked under proton. Still would rather it worked under Lutris, but no luck yet…