Star Trek Armada Drama

I have been trying to install and use Star Trek Armada (GOG version/tried an old CD installer as well - Same issue).

I have gotten the game patched to 1.2, then installed the 1.3 patch for basic widescreen support. I have also added some dx wrappers and attempted to run the dxcfg application that is installed via GOG.

No matter what I do, I am not able to bust the menu out of 640x480. I have gotten it to play once at 1920x1080, but as soon as the menu is accessed, it dies and I have to kill the app.

I know this is a troublesome game. My hope is that someone has a secret receipe on how to get it playable as much as possible.

Here were a couple of attempts to fix it to no avail.

stuck on 640x480:

Here is a link to what I’m seeing:

I’m having the same problem with Star Trek Armada 2.
The closest I’ve gotten to playing is playing in 640x480 in windowed mode.

Still troubleshooting.

@Admiralfeb Have you solved this yet?

I believe I solved for Armada 2.
I originally got it working in Bottles. I’ll have to double check to see if I got it working in Lutris.

I just kept tweaking display settings and starting the game.

The best playable state I got to was where the resolution would change for the machine until the game closed. However, if a notification hit or something, the game would bug and would shift to an unplayable state.

Okay. I’m in the situation where the game launches but the menu is off in the upper left of my screen and unable to correctly select anything. I was able to, somewhat, select the options in the menu to change resolution but it still did not fix the menu problem.

These are the configs I’m using for my game. It was February when I last attempted to play. I tried it just a moment ago and it all worked. I’m unsure where the game config is stored, whether it’s wine or lutris, so I screencapped the settings for you. Note: This is the GOG version of the game and was installed using the GOG exe. I think the lutris script pulls or asks for it now.

It only allowed me to attach one, so if the cap doesn’t help, I’ll grab more.

Thank you.
The only difference in mine is the Wine version, of which I have lutris-fshack. I tried changing it to System but it would not launch at all.