Back to the main site

Star Citizen no audio

So I had installed Star Citizen before I had found the community provided Quick Start Guide & the LUG Helper and the game launcher had audio no problem. Just the game runtime would fail to launch so once I found the guide and Helper I reinstalled from scratch following it.

The Guide said to “Under System options, make sure Prefer system libraries is Off.” I assume this is so we make sure lutris/wine are using specifically the libraries we want it/them to use.

But now while the game launches fine there is no audio, not even in the launcher. Which likely means it’s not using the right audio library. Here’s a log:

lutris-wrapper: Star Citizen
Started initial process 45431 from /home/user/.local/share/lutris/runners/wine/wine-lutris-GE-Proton7-15-SC-x86_64/bin/wine /run/media/user/GAMES/CloudImperiumGames/drive_c/Program Files/Roberts Space Industries/RSI Launcher/RSI Launcher.exe
Start monitoring process.
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
wine: configuration in L"/run/media/user/GAMES/CloudImperiumGames" has been updated.

ALSA lib dlmisc.c:337:(snd_dlobj_cache_get0) Cannot open shared library libasound_module_pcm_pulse.so (libwrap.so.0: cannot open shared object file: No such file or directory)
ALSA lib dlmisc.c:337:(snd_dlobj_cache_get0) Cannot open shared library libasound_module_pcm_pulse.so (libwrap.so.0: cannot open shared object file: No such file or directory)
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
[07:45:36.316] [info] Installer Option: concurrentTransfers to 15
[07:45:36.325] [info] Installer Option: maximumDownloadBandwidth to 10485760
[07:45:36.612] [info] { event: 'AUTHENTICATION_AUTO_LOGIN' }
[07:45:36.614] [info] { event: 'AUTHENTICATION_SUCCESSFUL',
  data: 
   { heapAccountId: { cookie: '_rsi_device', key: 'X-RSI-Device' } } }
[07:45:36.646] [info] { event: 'INITIALIZATION_SUCCESSFUL' }
[07:45:37.865] [info] { event: 'SELECT_GAME_SUCCESSFUL',
  data: { channelId: 'LIVE', gameId: 'SC', platform: 'prod' } }
Checking for update
[07:46:22.607] [info] { event: 'LAUNCH_GAME' }
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
[07:46:23.632] [info] { event: 'LAUNCH_GAME_READY',
  data: 
   { channelId: 'LIVE',
     gameId: 'SC',
     gameToken: 'eyJ0eXAiOiJKV1QiLCJhbGciOiJSUzUxMiJ9.eyJpc3MiOiJodHRwczpcL1wvcm9iZXJ0c3NwYWNlaW5kdXN0cmllcy5jb20iLCJpYXQiOjE2NTk1MDE5ODMsImV4cCI6MTY1OTYwOTk4MywianRpIjoiZjZzd3VjYWs0N2JwYSIsInN1YiI6ImdhbWVcL1NDXC8zZjNlZGUyOWYyOWM0YjljODk3OTEyN2RlYjU0ODVlOTA3NjMxNGI5IiwiYXVkIjoicnNpXC9nYW1lXC9iZWFyZXIiLCJhY2NvdW50X2lkIjoiMjYzMzA5MCIsInBsYXllcl9pZCI6Ijk0MjExMzQwNDg5MiIsImRpc3BsYXluYW1lIjoibWVnYWxvbWFuaWFrYWFsIiwibmlja25hbWUiOiJrb2h1a2UifQ.A4Jn_ZXnAsGUr1EUpuQTqb_jhv7xVUm3DC31ByuGUBZEPz2ODmhmdUaX5Gtqm_m8t_OYyXDIcB8QIOyRENSqXAp6xizEAdHweUM4kv-w2wBy7PuzBLqTEIgh9pX8Ury0XcP1SeAMYPXxSge1OY7DL7mafaIxUEUcYLeVgbeq3ibAC5Ja_pgySQsrnv_0EhBq2yQWsjIWPnAVmK_EUjVGK9eRfDl_fnd1sXKiOZXnDCkKyGDu08VlXefJfVKx-uYYkTqcDd8cPIpmYDJ_zbcNuOQD0vXTEuFMYJc-JbUp0zn1y7xPBl3aqWi8sXsxJOvNR5_qSsl7r0J-OzXHb4Low-rdb5LjFalKdb140MfdrfKmj60nISQ9amIA_q0FLHWBboOsBBEcOqnBPXNNPGy5IlN5k-8-VE28c4ULWPEFXOWOv5aBDJ3LKLyDoYL43c7wVSTF4251lRy4fL76B0OgJ7d11ha_kxu73_431ao4b6ESwAlZsDIL6A7hkXEGb4t9I5EM2qwF3ZS3gNaoIL9aMfU-Sf8SauAVmNChOFJLD2ohiSnaKQmwtcIc-O79W-4Tm47rPq_1p4XCAG7n4HVj3nOiMqUGJDTViSTxQgNWk2QiKn4xsWdfb0shvGtS5HtNuBHfA7Zv0EQeYsdVvdcfBT76UwkWRedj1PFEbDMyH7k',
     platformId: 'prod' } }
[07:46:23.640] [info] Launching Star Citizen LIVE from (C:\Program Files\Roberts Space Industries\StarCitizen\LIVE)
ALSA lib dlmisc.c:337:(snd_dlobj_cache_get0) Cannot open shared library libasound_module_pcm_pulse.so (libwrap.so.0: cannot open shared object file: No such file or directory)
ALSA lib dlmisc.c:337:(snd_dlobj_cache_get0) Cannot open shared library libasound_module_pcm_pulse.so (libwrap.so.0: cannot open shared object file: No such file or directory)
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
ALSA lib pcm.c:8568:(snd_pcm_recover) overrun occurred
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
ALSA lib pcm.c:8568:(snd_pcm_recover) overrun occurred
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
Checking for update
Update for version 1.5.5 is not available (latest version: 1.5.5, downgrade is disallowed).
[08:52:03.121] [info] { event: 'TERMINATION' }
ALSA lib pcm.c:8568:(snd_pcm_recover) underrun occurred
Monitored process exited.
Initial process has exited (return code: 0)
Exit with return code 0

So just to test my hunch I momentarily re-enabled the Prefer system libraries and the launcher had audio again. What do? How do I supply it with the correct library and how to I determine which library to use? Or is the Guide just being a bit too conservative and it should be fine to simply leave the Prefer system libraries enabled?

Just for completeness I’ll add that I’m using Manjaro KDE with plasma-wayland because distro’s likely relevant. It’s been over a decade since I last used linux and I’ve only just returned a couple of days ago so please be patient with me, thanks.

TL;DR: with the Prefer system libraries enabled game works with audio, without game works but without audio. Might the guide just be a bit outdated and it should be fine to ignore the point it makes about having the Prefer system libraries off or should I try to stick to the guide and try and resolve the no audio problem through some other means? Just looking for some guidance/opinions for the sake of my own sanity.

1 Like

tried to resolve the no audio issues - this is new, it was working fine on my nvidia gpu manjaro setup. Laptop not working all of a sudden. I guess if no issues with sys libs turned on id continue and monitor. Thanks for this post I looked everywhere for a solution. Even rebuilt most of the libs.

1 Like

I’m having the same issue, I was also having the same issue with Crysis and the Sandbox2 editor, but those now work after enabling “prefer system libraries” Star Citizen crashes with system libraries enabled, it works with them disabled but sends the audio to my connected tv instead of my usb headset that I have selected.

Did you follow the quick start guide instructions from the LUG wiki and did you use the LUG Helper?

Nota bene, the quick start guide is a bit out of order: Deploy Easy Anti-Cheat Workaround is in wrong order and should come after Install Star Citizen

This sounds more like a system config issue, I’m assuming your connected tv is connected over HDMI which carries audio as well. What distro and what DE?