Space engineers

A search of space engineers turned up nothing. The game will not install. As I said in my script problem report - which I sent moments ago -, the script gets as far as the installing game data dialog box then hangs. I don’t think it’s starting Steam. It says it’s the steam installer. Will someone please fix the script so I can install it? Thanks.

Have you installed the Wine Steam runner and have you signed in?

Yes to both. I have installed many games in Lutris and they worked just fine.

Over the week end I checked and looked up the game. It said that space engineers no longer supports direct x 9 and even tho wine has improved on direct x 10 a lot the past year or so, It seems the game uses some direct x 11 and wine Is still lacking in dx11. Basically no body can run the game right now until wine devs improve DX11 support.


Since it’s DX11, have you tried with DXVK?

How do I try it with DXVK?

I found the switch to enable DXVK but it doesn’t work:

wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
wine: Call from 0x7b43d17c to unimplemented function mscoree.dll.CorIsLatestSvc, aborting
wine: Unimplemented function mscoree.dll.CorIsLatestSvc called at address 0x7b43d17c (thread 0017), starting debugger…

Unhandled Exception:
System.TypeInitializationException: The type initializer for ‘VRage.FileSystem.MyFileSystem’ threw an exception. —> System.MissingMethodException: Method ‘System.Collections.HashHelpers.IsWellKnownEqualityComparer’ not found.
at System.Collections.Generic.HashSet`1[T].Add (T item) [0x00000] in <31a9ee19f7d24051a5b4b803e6e691ce>:0
at VRage.FileSystem.MyFileProviderAggregator.AddProvider (VRage.FileSystem.IFileProvider provider) [0x00000] in <1820f8b723b043d9b74a51bcec9ffa4a>:0
at VRage.FileSystem.MyFileProviderAggregator…ctor (VRage.FileSystem.IFileProvider[] providers) [0x0001b] in <1820f8b723b043d9b74a51bcec9ffa4a>:0
at VRage.FileSystem.MyFileSystem…cctor () [0x00061] in <1820f8b723b043d9b74a51bcec9ffa4a>:0
— End of inner exception stack trace —

that’s a .NET error, not a DirectX one.

I know there are some issues with properly installing .NET with the current version of Winetricks, this might be related.