Back to the main site

Source does not exist -- TES: Arena

Clicking install on the lutris website on the gog version script that provides me with the installer or lutris itself always results in this error: http://i.imgur.com/tGrs6u0.png

This happens every time after I select the path for the gog installer and click next.

This is my very first attempt at installing a game through lutris. I’m sorry if I’m missing some obvious documentation.

My guess is the install script was written for a different GOG installer version.

Hello Regath, the script was obsolete, I completely rewrote it, could you give it a try?
As it is not yet validated by moderator, you have to follow this steps to test it:
Click “Edit installer”, “Test this installer”

Thank you legluondunet. Unfortunately I’m still receiving the same error, though this time the installer made Dosbox appear in my list of runners! Selecting Dosbox gives: No games found. The error appears in the same spot – after clicking next after I’ve selected the installer .exe and see the console appear for a split second.

Am I using the wrong version? Or should I rename the file?

Could you make a new install following this steps:

  1. erase this folder: ~/.cache/lutris/installer
  2. start Lutris in debug mode, in a terminal type this command:
    lutris -d > lutris.log
  3. if already installed, uninstall (remove) TES Arena
  4. click on this url:
    https://lutris.net/games/the-elder-scrolls-arena-gog/installer/edit
    and click “test this installer”
  5. post the lutris.log debug file to this thread

INFO 2019-09-01 22:05:04,989 [application.do_command_line:225]:Running Lutris 0.5.2.2
INFO 2019-09-01 22:05:04,990 [startup.check_driver:60]:Using Intel Open Source Technology Center
INFO 2019-09-01 22:05:04,990 [startup.check_driver:65]:Running Mesa driver 19.1.2 on Mesa DRI Intel® HD Graphics 5500 (Broadwell GT2) (0x1616)
INFO 2019-09-01 22:05:04,991 [startup.check_driver:75]:GPU: 8086:1616 17AA:5034 using i915 drivers
INFO 2019-09-01 22:05:05,242 [startup.check_vulkan:129]:Vulkan is supported
INFO 2019-09-01 22:05:05,243 [dxvk.get_dxvk_versions:24]:Updating DXVK versions
DEBUG 2019-09-01 22:05:05,424 [http.get:68]:GET https://lutris.net/api/runtime
2019-09-01 22:05:37,892: Running Lutris 0.5.2.2
2019-09-01 22:05:37,892: Using Intel Open Source Technology Center
2019-09-01 22:05:37,892: Running Mesa driver 19.1.2 on Mesa DRI Intel® HD Graphics 5500 (Broadwell GT2) (0x1616)
2019-09-01 22:05:37,893: GPU: 8086:1616 17AA:5034 using i915 drivers
2019-09-01 22:05:37,901: Vulkan is supported
2019-09-01 22:05:37,906: Fetching installer https://lutris.net/api/installers/the-elder-scrolls-arena-gog
2019-09-01 22:05:37,906: GET https://lutris.net/api/installers/the-elder-scrolls-arena-gog
2019-09-01 22:05:42,435: Retrieving video modes from XrandR
2019-09-01 22:05:46,611: Required runners: [<lutris.runners.dosbox.dosbox object at 0x7f45e76b6ef0>]
2019-09-01 22:05:46,614: Unable to get the game from GOG: The installer has no GOG ID!
2019-09-01 22:05:46,616: Downloading file 1 of 2
2019-09-01 22:06:04,060: Downloading file 2 of 2
2019-09-01 22:06:04,062: Downloading [file2]: https://lutris.net/files/tools/innoextract.tar.gz to /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/file2/innoextract.tar.gz
2019-09-01 22:06:04,067: Downloading https://lutris.net/files/tools/innoextract.tar.gz to /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/file2/innoextract.tar.gz
2019-09-01 22:06:04,071: Starting download of:
https://lutris.net/files/tools/innoextract.tar.gz
2019-09-01 22:06:05,000: Finished downloading https://lutris.net/files/tools/innoextract.tar.gz
2019-09-01 22:06:05,075: Installer command: {‘extract’: {‘dst’: ‘$CACHE’, ‘file’: ‘$file2’}}
2019-09-01 22:06:05,081: Extracting innoextract.tar.gz
2019-09-01 22:06:05,082: extracting file /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/file2/innoextract.tar.gz to /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena
2019-09-01 22:06:05,106: Extracting /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/file2/innoextract.tar.gz to /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena
2019-09-01 22:06:05,137: Removing folder /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/.extract-5bab66e0
2019-09-01 22:06:05,138: Finished extracting /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/file2/innoextract.tar.gz to /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena
2019-09-01 22:06:05,139: Installer command: {‘execute’: {‘args’: ‘-d “$CACHE” “$file1”’, ‘file’: ‘$CACHE/innoextract’}}
2019-09-01 22:06:05,142: Running /usr/bin/lutris-wrapper 0 0 /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/innoextract -d /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena /home/mantas/Downloads/setup_the_elder_scrolls_arena_1.07_(28043).exe
2019-09-01 22:06:05,143: ENV: STEAM_RUNTIME="/home/mantas/.local/share/lutris/runtime/steam"
2019-09-01 22:06:05,143: ENV: LD_LIBRARY_PATH="/home/mantas/.local/share/lutris/runtime/Ubuntu-18.04-i686:/home/mantas/.local/share/lutris/runtime/steam/i386/lib/i386-linux-gnu:/home/mantas/.local/share/lutris/runtime/steam/i386/lib:/home/mantas/.local/share/lutris/runtime/steam/i386/usr/lib/i386-linux-gnu:/home/mantas/.local/share/lutris/runtime/steam/i386/usr/lib:/home/mantas/.local/share/lutris/runtime/Ubuntu-18.04-x86_64:/home/mantas/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu:/home/mantas/.local/share/lutris/runtime/steam/amd64/lib:/home/mantas/.local/share/lutris/runtime/steam/amd64/usr/lib/x86_64-linux-gnu:/home/mantas/.local/share/lutris/runtime/steam/amd64/usr/lib"
2019-09-01 22:06:05,143: ENV: PYTHONPATH="/usr/bin:/usr/lib/python36.zip:/usr/lib/python3.6:/usr/lib/python3.6/lib-dynload:/usr/local/lib/python3.6/dist-packages:/usr/lib/python3/dist-packages"
2019-09-01 22:06:05,147: Registering <bound method MonitoredCommand.on_stop of <lutris.command.MonitoredCommand object at 0x7f45e76d1fd0>> to 2375
Running /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/innoextract -d /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena /home/mantas/Downloads/setup_the_elder_scrolls_arena_1.07_(28043).exe
Warning: Unexpected setup data version: 5.6.2 (unicode)
Warning: Unexpected Uninstall Log Mode value: 19
Warning: Unexpected Compression Method value: 20
Stream error while parsing setup headers!
├─ detected setup version: 5.6.2 (unicode)
└─ error reason: basic_ios::clear
If you are sure the setup file is not corrupted, consider
filing a bug report at http://innoextract.constexpr.org/issues
Done with 1 error and 3 warnings.
Waiting on children
Exit with returncode 2
2019-09-01 22:06:05,273: The process has terminated with code 512
2019-09-01 22:06:05,274: Management process looks dead already.
2019-09-01 22:06:05,274: logger already detached
2019-09-01 22:06:06,151: Installer command: {‘merge’: {‘dst’: ‘$GAMEDIR’, ‘src’: ‘$CACHE/app’}}
2019-09-01 22:06:06,157: Merging /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/app into /home/mantas/Games/the-elder-scrolls-arena
2019-09-01 22:06:06,158: Source does not exist: /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/app
{‘dst’: ‘$GAMEDIR’, ‘src’: ‘$CACHE/app’}
2019-09-01 22:06:06,159: Error while completing task <bound method CommandsMixin.merge of <lutris.installer.interpreter.ScriptInterpreter object at 0x7f45e76d1208>>: Source does not exist: /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/app
{‘dst’: ‘$GAMEDIR’, ‘src’: ‘$CACHE/app’}
<class ‘lutris.installer.errors.ScriptingError’> Source does not exist: /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena/app
{‘dst’: ‘$GAMEDIR’, ‘src’: ‘$CACHE/app’}
2019-09-01 22:06:15,050: Install cancelled
2019-09-01 22:06:15,051: Removing folder /home/mantas/.cache/lutris/installer/the-elder-scrolls-arena

@regath you are not using my modified script, you didn’t follow this steps:

As it is not yet validated by moderator, you have to follow this steps to test it:
Click “Edit installer”:

then click “Test this installer”

No, I definitely am and have been.

To be specific, that latest submission by you that was selected by default.

Selecting it and pressing “Test this installer”.

I saw in your debug log the script downloaded:
https://lutris.net/files/tools/innoextract.tar.gz
I have a different url in my script…
So you didn’t use my script.
Try again and post a new debug log.

I selected back and forth between random drafts and then this submission. It still shows that same url on the top.

Why not just paste your script here and I’ll just copy paste it into that window, then press Test?

ok, I don’t understand why you can not see the modified script. You have to wait until a moderator validate it.

1 Like

Could you just paste the script here so I can paste it into the box on the script editor?

you will find it here: https://github.com/legluondunet/MyLittleLutrisScripts/blob/master/The%20Elder%20Scroll%20-%20Arena

Just so there’s no misunderstandings: pressing “Test” runs the selected saved version, so you’ll need to post it first.

Well, I’ve tried playing around with the files then, couldn’t really figure it out. Going back to the Arena scripts website there’s more submissions. Selecting the latest (09-02 13:32:20) gives me an install for another game (The Longest Journey) and selecting the previous (09-02 12:57:15) gives me the same thing. Selecting one more back (09-01 10:01:08), which was causing the Source does not exist error, is now throwing me back the one forward (09-02 12:57:15). No matter which script I select, they ALL show the exact same code, including the innoextract link.

Hey Regath, you gave or we have no news because you are playing the game?

I apologize, I’ve had to deal with certain things IRL, so I was away and had no time to do anything.

I do highly appreciate you helping me, even if it may not seem like it. I wish it was just a simple solution. I do feel bad for demanding so much.

Back to the game, I see a bunch of new submissions, but they’re all absolutely identical on my end (same script from the log) and give me the same outcome.

No problem, I just asked a moderator to validate my installer update.
I hope he will validate it this evening.

1 Like

A moderator updated script, could you get a try?

1 Like

Hey, it seems to be working well, but I don’t have the time to properly test it at this moment. The only “problem” I have is that global shortcuts don’t work like alt + tab or fn + vol up/down.

Thank you very much for your help man. :slight_smile: