Back to the main site

Sometimes laggy mouse when seeing stuff in WINE apps/games

Hey mates!

Ok, so I might lack the right terms here, but I try to explain it. I don’t have any idea where this comes from.

Most of the time when running stuff via Lutris, everything works fine. On some occasions though (maybe every 4th reboot?), I get a hard mouse problem.

It seems like restarting Lutris/WINE doesn’t change anything about it. It’s more like either that problem is there this time, or I have to fully reboot to get it away (or have it again).

It is that upon starting an app (examples Origin or Battle.net or League Of Legends client), my mouse gets sluggish/laggy. It is like it doesn’t have its full Hertz rate, or not every command is being read upon input.

Funny enough, this only happens, if I’m at the same virtual desktop, where the app runs. So if the app is running, but I switch to another desktop, everything is fine again. When going back to the app-desktop, my mouse is unuseable again.

I also think this has something to do with the drawing of the windows. A good example is Origin: If nothing is changing in the Origin app, my mouse feels kinda fine. But as soon as I hover a button, which then has an animation, as long as the animation goes, my mouse won’t really work.

Unfortunately, on apps like the League Of Legends client, there is always some animation, so the mouse problem persists.

If I minimize this app window, mouse is fine again, though being on the same virtual desktop. So it might have something to do with the window draw event?

For LoL and Origin, this is uncomfortable, but useable: Try to click on the “start game” button with a shitty mouse, but then the client minimizes and the game just runs fine.

Unfortunately again, this problem persists with Diablo 2 Resurrected, where ingame my mouse is unuseable, but I also don’t have my full performance of my GPU. nvtop even tells me, that D2R uses ~100% GPU performance, but I get like 15 FPS ingame. This is despite having the Battle.net-app on another virtual desktop, or even closing it while playing.

nvidia-settings though tell me, that the card (RTX2080) is running in performance mode and on the highest settings - so it’s not like this card isn’t scaling with the game.

I’m kinda helpless with this problem and I don’t even know where to troubleshoot.

Closing ALL apps, etc. won’t do anything about it. Only when I fully reboot it could be normal again - but also with a chance that it doesn’t, as sensed every 4th reboot has this problem.

I’m running on Manjaro with KDE Plasma, everything up-to-date. I have this problem since several months now, but well, before that it was just annoying. Now it renders my Diablo 2 game unuseable.

Do you have any idea on what I could check that could invoke this problem?

1 Like

Just an idea here, but have you tried toggling off the compositor in KDE/Plasma before starting your games? I always would, if using Plasma. It doesn’t suspend it automatically.

It’s easily done, the last time I used Plasma for games, ALT+SHIFT+F12 seamlessly toggled it off and on.

Yes, already tried this. :confused:

I tried:

  • toggling off when problem is there
  • toggling off before I do anything on my PC
  • toggling furiously between to see if it goes away

Seems like it’s not a KWin thing.

This being said, launching via Lutris often does toggle compositor, but on some days I can do that a hundred times and not have the problem. Either I’m too stupid to find the trigger, or it’s really a “either on this boot cycle you have the problem or not”.