Back to the main site

[Solved] Wrong mapping for XBox Wireless (Bluetooth) Controller

Hi! I’m currently trying to use the XBox Wireless Controller with Lutris (connect via built-in bluetooth, no dongle). The problem is that the controller mapping is wrong and I have no idea how to remap it. However, this only happen with wine and Lutris (various version) but not with steam proton and native game. My DE, plasma, detect input correctly in the settings.

This picture was captured in wine control panel. It showed the default stage of the controller.

The position of X,Y,Z,Rz returned to center after using left and right joysticks. Pressing LT and RT return the input back like in the picture. In this whole time Rx and Ry didn’t move. POV registered the D-Pad buttons.

This cause camera in game to move down and spin. I tried install xpad-neo but it didn’t fix it. Again, it work with steam and native game.

System specs:
OS: EndeavourOS Linux x86_64
Kernel: 5.13.13-zen1-1-zen (linux-zen)
DE: Plasma 5.22.5
CPU: Intel i7-7700HQ (8) @ 3.800GHz
GPU: NVIDIA GeForce GTX 1050 Mobile
RAM: 16GB

1 Like

I actually found the solution from reddit. Basically, I have to edit registry.

1 Like

Hey there,
I had the same problem with my Xbox one S Controller via BT on Arch Linux.
To solve this problem I installed a different driver, xpadneo: https://github.com/atar-axis/xpadneo/
It works ootb like a charm and even more options for configuration.
Maybe the same works for you too.

1 Like

xpad neo ftw, I wish it was just part of xpad though…