[Solved] WoW installs fine and seems to be running, but does not display

Hi there,

So I’ve installed WoW using Lutris (Dox (August 2018) version). I’ve done this two ways:

  • first using the Battlenet launcher from my Hearthstone installation;
  • then, since it did not seem to work, I tried again on a fresh WoW installation, with a different launcher, to get the specific prefixes that WoW might need

The second time I followed these steps ahead: https://github.com/lutris/lutris/wiki/Game:-Blizzard-App

In both cases I add the same result:

  • the Battlenet launcher works fine;
  • WoW installs fine;
  • when starting WoW from he Battlenet launcher, the launcher says the game is running and minimize;
  • I can then see WoW.exe running with top, using a whole CPU;
  • I get no obvious error message when launching Lutris from command line
  • but WoW does not display, the desktop is still there, I don’t have a black screen or anything, it just seems like WoW is not running (I’ve tried waiting about 10 minutes to see if it was only super slow, it still did not start).

Since I have no idea what’s going on, I’m having troubles debugging that… Is there any log or verbose mode that could give me more information? Or has anyone seen something similar?

Thanks for reading!

Since you give 0 info about your setup, I’m going to guess that your issue is: very old drivers.

Please tell us: Distro? Gpu? Driver? And the output of glxinfo -B

If you want to debug yourself: Start Lutris in terminal with lutris -d. Enabled debugging output for the game - check logs. And you could post them here aswell.

I though I add updated the drivers, but apparently the update had failed. glxinfo -B helped me to notice that, then I did several apt-get things until glxinfo -B showed the right version. It fixed everything indeed!

Thanks for your time, and sorry for being stupid! :blush:

Mark your thread as solved. Edit the topic and add [Solved] or something. Not sure how it works here.