Solved: WoW Dragonflight just closes

So I’ve been playing WOTLK the entire morning with no problem. Then I realize that the Dragonflight prepatch has gone live so I wanted to check it out.
Started fine. Logged into a character. Gone. The Client just closed. Battlenet still running. Tried again, addons disabled, Cache Folder deleted. Seemed to work. Stared a bit at the new interface, checked the map but as soon as I moved the camera the game closed again. No freeze before, no stutter, just a “clean” exit. No error, nothing. I was on Kernel 5.18 because 5.19 seemed to cause error 132 in WOTLK which is my main game. So I updated to 6.0, started Dragonflight, logged into a character in Stormwind who happened to be still on a flying mount. I waited a bit to see if something happens. after nothing happened for a minute or two I hit space and manage to fly up a couple of meters when the game closes again. I tried a few more times. So far the game crashed at any stage imaginable. while loading, right after I log in to a character (I saw maybe one frame and the game was gone again)
Shadowlands, just a few days before worked fine.

lutris -d Output:
But it doesn’t produce any more messages after battlenet has started. even after dragonflight just closes.
There have always been that many “Failed to load Plugin” Errors. Never was a problem.

I’m on manjaro with kernel 6.0 (and 5.18 before)
Ryzen 5 3600, AMD Radeon 580 & 32G of RAM.

Surprised I’m the only one with this issue so far. Hope anyone has a solution.

Edit: Just managed to check my mail on one character and walk around a bit. even shaked the camera and the game was gone. Tried again. managed to walk through SW even shaked the camera a bit. nothing happened. randomly closes later on when I was just walking.
Just managed to “play” for a few minutes and it closes again AND started right after and I was back logging in and at the character screen

1 Like

The launch was terrible - SW and Org were unavailable, character stuck service was overloaded, people jumped into the Maw and were left hanging. Client crashed on Win 10 for me. This morning it seems much better BUT I think the hardware requirements are much higher now. My FPS is very low (6700xt/11600k/3600C15 Gear 1 DDR4) compared to 2 days ago. I am getting large drops down to 40-50fps when I turn around (from over 100). Still this happens every time they launch a new xpac, was terrible when Burning Crusades dropped - have my guild left over the software issues.

Same. With the update it just started closing on world load. I can get into character selection every time with no problem but it just crashes once the world loading bar gets to max and before the world actually loads. I have a Radeon 570 with 16GB and and olde timie FX-8320. I wonder if this is a Vulkan issue on our version of the drivers?

I upgraded to the pre-patch and apart from the typical lua errors when changing addons, I only noticed a drop in frames (from 70-100 to 50 approximately). I haven’t entered dungeons or gangs yet and I don’t know how they will work, but I think you have to leave a margin of error for Blizzar to adjust the new patch. And knowing that with each patch or extension the hardware requirements will go up. Another thing is constant errors that do not allow you to play.

I use Debian Testing; Kernel 5.19-11.1 and Nvidia 750 Ti.

If you still can’t play, let us know if we can find a solution.


Translated with DeepL Translate: The world's most accurate translator (free version)

Hi! Thanks for this. I used ProtonUp-Qt to install the latest version of proton in Lutris and switched it as my runner. Working beautifully now. Some slight stuttering while compiling shaders at first but otherwise working great.

@barren Maybe this will work for you as well?

Switched the runner to lutris-GE-proton7-32-x86_64, didn’t use protonup-qt, just used lutris to install it. so far (90 minutes) it runs fine but that doesn’t have to mean anything. It was running fine for about 45 minutes yesterday before closing again. will update this reply in a few hours.
battlenet also installed a little update today after switching the runner so maybe that might have fixed it?

Didn’t really notice any performance issues. Played for about 90 minutes now. no crashes, stable 60fps, gpu fans kick in in crowded areas but mostly >50 fps. totally playable.

Update: over 3 hours of playtime now. no issues with lutris-GE-proton7-32-x86_64. THANKS!
Another Update: Two days later still no issues.

1 Like

Just tried it with default settings and changed the runner to lutris-GE-proton7-33-x86_64 - it closes just before loading the character.
Character screen works fine.

I’m runnining Manjaro 21.3.7 (Kernel version 5.15.76-1)

Aynone experience the same?

Check in the Program Files (x86)/World of Warcraft/_retail_ folder for an Errors folder. If it is present, look in one of the .txt file and see if it mentions sapi.dll
Normally this occurs when the sapi.dll is missing. You can use Winetricks to add it to your WoW prefix

There’s no error folder inside _retail _.

I tried logging in this time, and I was logged in for approx. 1 second before wow.exe automatically closed.

Edit: Running wow.exe and not the battle.-net launcher might mitigate this issue. It’s been running for 10 mins now without crashing. Unfortunately, I won’t appear online in Battle.-net then.

Edit: Running wow.exe through battle.-net now causes the OS to freeze. It feels like a memory leak.

Check if sapi.dll is in your prefix using Winetricks also set to exit completely when you launch a game (it dying in the background might be taking down the game client)

Thanks jhu,

I tried doing both things, but it works after adding sapi.dll in the prefix in Winetricks, no matter if is closed or not :slight_smile:

It’s been running 30 mins before I manually closed it both with open or closed :slight_smile:

1 Like