Back to the main site

[SOLVED] WoW Classic - Public Test Realm crashes/hangs on load

The WoW Classic PTR was recently updated to include the pre-patch for the next expansion, so I downloaded and installed the PTR and when I tried to launch it it only went to a black screen.

To fix the black screen I tried to run regular TBC first, which worked fine. After I ran normal TBC I could now run the PTR up until I pressed Enter with a newly created character. Here the game either crashed or hang. The furthest I got was the game loading me into Orgrimmar and I could see other players running around but it soon started hanging.

I’ve tried various different wine runners, and nothing seems to work. I’ve tried both DX12 and DX11, both works fine for live TBC. I also tried using the fix posted here, but did not help.

5.15.57-2-MANJARO
Nvidia GTX 1070 - Drivers: 515.57

Lutris log:

Any suggestions how to proceed?

1 Like

The fix in the link you posted is specific to a 132 error with a crash log being generated showing d3d12.dll error (the d3d12.dll was unloaded while vkd3d was still using it in the cache mode). If you do have a 132 error message, check in the World of Warcraft game folder for the classic / errors directory and see if a .txt file is generated. This will point to a WoW error versus a WIne error

I did get a 132 error, which is why I tried with the fix I linked. It seems to have solved that crash, but I’m still facing the issue where the game freezes/crashes when loading in.

After doing the sapi.dll fix I don’t get any files generated in classic_ptr/errors directory.

so you had the sapi.dll missing too… No errors and the game still crashes on PTR but no issues on classic TBC - any mention of this on Blizzard forums? Also, just for kicks, disable Lutris runtime in the System options on Lutris, enable hardware acceleration on Battle.Net, and change the runner to the latest Wine-GE. Probably won’t do anything. Also, if you run lutris -d from Terminal, is there any mention of wineserver crashing?

Could not find anything on the Blizzard forums no :confused:

I tried running it twice, both time with dx12. Once with default settings and once with what you suggested here

(Could only post one link)
wine-ge:

Not that I can see, and when the game do exit battlenet is still running so I guess wine is up and running then still.

Do you have access to ProtonUp-Qt? Latest Wine GE is lutris-GE-Proton7-25x86_64. Worth getting this one as a starting point from ProtonUp or the Wine GE git pages.
I am going to download the PTR to see what is happening - will be tomorrow, bit late here now.

My bad, thought the GE-Proton was for proton only :slight_smile:

Tried with lutris-GE-Proton7-24x86_64, battle.net only went black so I used wow executable instead.
Same issue
https://pastebin.com/mJbsKyfP

Well it didn’t take too long to download and install the Classic PTR. Tried the Normal and PVP realms, not many people on the PVP so my fps was in the high 400’s, switched to Normal realm in Orgrimmar my fps dropped to the mid 100’s, but did notice some hard lag spikes. What CPU and memory are you running with the 1070? Is the game installed on an SSD/nvme drive? I was able to run out and explore the city area. Seemed Ok and no crashes. Also running the Beta battle.net launcher too. It did go black on first launch, but second time in with hardware acceleration enabled in settings, Lutris runtime disabled and 7.24 runner, everything was fine.

I have a i7 4770k, 16GB RAM and its installed on a SSD. Will try beta launcher next time then.

Ran with 7.24 runner, Beta battle.net launcher, Lutris runtime disabled and reinstalled and still nothing. I load into the city and then it just closes the game.

What settings are you using in game? I am on an 11600K and it felt bad loading into the normal realm. Classic runs well with either dx11 or dx12 on your machine and your basic game setup mirrors what I am using now, it seems like the PTR WotLK is not well optimized atm. Also, I suspect with the large number of players right when you load in is not helping - I went from 400+ fps to 100 fps same load area between PVP and Normal.
Try setting the quality settings to like 3 or lower from the menu before you load into the game.

I disabled v-sync and now it works :slight_smile: Thank you for all your help, not sure if it was just v-sync or a combination of all the things you suggested but now it seems to be working

1 Like

Ha - yes vsync was enabled on mine as well, turned it off and the massive lag spikes I saw stopped, now very smooth. Happy gaming