[Solved] WoW causes computer delay/lag when it loses focus

Ok, so WoW and battlenet work fine for the most part. In terms of actual gameplay it’s fine.

The issue comes when I tab out of WoW or just switch focus to any other application or program. If I switch focus once it could cause the issue right away or sometimes it takes 10 times of switching between applications.

Now, once the issue presents itself my computer lags heavily for lack of better words. It takes 5-20 seconds to complete any action. It’s more akin to freezing, then catching up, freezing for 5-20 seconds, and then catching up again, and so on… This lasts until I kill WoW from the system manager or force shutdown my computer.

As for WoW itself, it becomes unresponsive and freezes completely.

Something to note… I’ve seen people have a similar issue when you tab out of a fullscreen game. I’ve tested both Borderless Window, and Windowed mode and I can still reproduce the issue on each setting. WoW does not have true Fullscreen as an option anymore due to exploits.

Thanks in advance!


Lutris --submit-issue: https://paste.ubuntu.com/p/DG4txmGRQF/
Game log Output: https://paste.ubuntu.com/p/tKWYvvcbDN/

EDIT: Let me know if the “Game log Output” link doesn’t show you anything. I’ve been having issues with it showing up but it may just be on my end.

I get oddities while it is OUT of focus, but upon returning, things are normal damn near instantly.

Now, to ensure we are talking about similar things:

  • Dual screen setup with game on one scree, other apps (chat, browser, irc, etc) on other.
  • GNOME 3.32

I hit the windows key to release the cursor, activate alternate program (usually Riot or Discord), mouse back in.

I only have one screen but have 4 desktops setup on said screen. I have WoW on one of those desktops and then discord or a browsers on others. If I focus on any of them I get the lag/delay. I’ve tried windows button, alt-tabbing… etc to switch between applications and it still causes the issue.

Something interesting came up just today though. I was just messing around and I swapped my desktop from Ubuntu 18.04s default to Unity (That option you have at login) and this allows me to switch between applications if WoW is in Windowed mode. If I switch it to Borderless Windowed mode however the problem still occurs.

I’ll continue keeping it in Windowed mode for know, however the performance is significantly worse.

EDIT: I’m GNOME 3.28.1

Alright. I was using Ubuntu 18.04 at the time of submitting this. After comparing my GNOME version with schotty’s I decided to look into updating it. Ubuntu 19.04 has a more up to date version of GNOME.

After I updated my OS to Ubuntu 19.04 reinstalled WoW on Lutris it seems to have fixed the problem… at least so far. I haven’t tested it extensively as I’m busy with my studies.

Updating my OS also solved a few other issues I was having that was not Lutris related so… win win!

1 Like