[SOLVED] WOW black screen with sound and cursor

Try just 1.7.1 L

https://imghub.io/i/EsdSt like this

I solved the problem by changing gxapi to directx11 instead of 12 in config.wtf.

1 Like

I’m a complete Linux noob, so could you kindly explain me step by step how to “changing the version of DXVK (configure World of Warcraft / Runner option) to 1.7.1L” please? Thanks in advance =)

For some reason, I can’t seem to find the config.wtf file :frowning:

cd ~/Games/world-of-warcraft/drive_c/Program\ Files\ "(x86)"/World\ of\ Warcraft/_retail_/WTF in a terminal session.

the config.wtf is located in this directory. If you are using classic WoW, change retail to classic

1 Like

No files in the WTF folder, sadly :frowning:

Have you followed the Lutris Battlenet installer instructions, downloaded the game and logged into your Battlenet account? Do you have a Windows installation of WoW you can access?

Yes, I installed Battle.net according to the instructions in the Lutris website, the folders are there (executable, libraries, data files, etc.) but no config.wtf file though.

In the WTF folder, you should have 2 folders created:


Do these exist? Have you ran Battlenet and logged into your account successfully?

I can log in bnet just fine. However, that folder is empty, probably because I haven’t been able to log in the game proper yet, so no account info and no variables to be saved either. Just guessing, though. The worst part is that when I launch wow, I can see the mouse pointer and hear sound. The screen, however is fully black.

Hi guys.

I have the same issue if I use Wayland and with Xorg works perfect. Rest of application with Wayland there is not any problem. Could it be Nvidia driver? Also I don’t know if lutris is supporting Wayland. Add I have tried with DX11 like our guy has commented getting an error. Anyone have the same issue?

If you or others still have problems finding the config file I have a work around.
Launch Battle.net with DXVK 1.7.1 the game should work fine, then in the settings change from DirectX 12 to 11, quit the game, set DXVK back to default and relaunch.

1 Like

I solved the issue by switching to Kubuntu 20.04 and launching WoW with Wine 5.0.5, since 6.0 had some audio glitches and everything above 6.0 was borked for me. Oh, I added the -d3d11 modifier to the battle.net command line (in game settings) in order to not get more blank screens.

Consider me a Linux Ubunter newberry :slight_smile: I followed the instructions at this link “https://linuxconfig.org/how-to-play-world-of-warcraft-on-linux-with-wine” and installed all the stuff I needed before Lutris. Installed Lutrus, installed Blizzard, downloaded wow-classic while under the Blizzard Wine runner, and got the described black screen with sound and cursor.

I switched the DIVK to the 1.7.1L as recommended above, and then noticed I couldn’t find a WTF folder thru search either.

I then downloaded wow classic, but NOT using the battle net launcher. (it’s a new WINE runner) I then launched it beautifully :slight_smile:

I hope that helps anyone else who has the problems.

If you are looking to improve World of Warcraft playing experience, I would recommend the Lutris-GE-6.16-2-LoL runner with dxvk v1.9.1L-2. This enables the resizable bar options for dx12 (VKD3D_CONFIG=upload_hvv) which can give a sizeable fps boost on support cards and for Navi cards, add RADV_PERFTEST=nggc to improve dx11 and dx12 performance. Also, make sure you disable the hardware acceleration in the battle.net launcher settings.
If you follow the guide for installing battle.net, you need to complete its installation, close it down (do not install the game straight away) and launch the new battle.net game from Lutris after configuring the runners etc then install the game through the battle.net launcher after it has patched itself to the latest build.

changing “Vulkan ICD Loader” from “auto” to “nvdia ICD” in “Configure → System Options” fixed my problem

I have just registered an account for this. After six hours of intensive research this really solved my problem. No needed to change dxvk version nor wine. Just do this. I have added a screenshot to demonstrate where I exactly put this parameter:

In case if screenshot gets wiped out of internet, here’s the clearer steps:
As by 2022 april

  • Open battle.net
  • Go to game settings (either click gear icon near play button or click battle net icon on top left corner then settings)
  • Under world of warcraft, click the checkbox: Additional command line arguments
  • Add this parameter exactly INCLUDING the dash (the little line before d letter) -d3d11
  • Launch the game
  • Magic!

Man, thank you very much! You made my day! Kiss kiss

Can confirm, this worked for me too! -d3d11

1 Like

The suggestion from 0xdeadc0de works - all setting default, just add the -d3d11 attribute and run the game.