[SOLVED]Wow 8.1 patch without bfa expasion UI can't open bags

lutris 0.4.23-1
DXVK 0.81
Enable Esync

I got several issues and my guess is that they are related to patch 8.1 since I have been replaying the game for about a month without any issues. Beside a strange workaround entailing having to download a Cache folder of the webs since the default one would log me off my account immediately with an streaming error.

However after the new patch things have changed. This could of course be some coincident and what ever broked just happened to more or less correlated with the patch.

I have now reset Cache, Interface, WTF folders but the issues persist, just as I have reinstalled the game which I would suppose rules out any corrupted files since it creates a new wine directory.

  1. Not always but mostly can’t open bags by clicking on them. Can open with keybinding B. Just as right clicking on items in bag mostly wont work.

  2. Can’t sell to vendors plus other similar issues, keybinding, animation getting stuck etc.

More UI related issues that randomly come and go but I’LL assume that they are all related.

There is obviously a bunch of solutions coming up when googling issues like this but they seem to end up saying pretty much the same,reset Cache, Interface, WTF folders.

ps Also, I would say about the same time, as the other issues occurred I started experiencing shuttering but this seems to be, can’t say for sure without further testing, remedied by disabling compositing which also in my case at least seem to result in better minimum fps. Where with compositing enabled I could get raid fps as low as 10-15 which is basically unplayable.

I use tkg-3.21 + DXVK 0.93 + Esync on Slackware64-14.2
And, oh yes, my desktop is just fluxbox.

Question: Does the clicking problem act differently when you exit the game client completely and restart it?

I keep Lutris Runtime enabled and prefer system libraries in the Lutris game config.
Oh and I have 2 Lutris installs;

  1. To launch Battle Net, I use World of Warcraft Launcher.exe
  2. To run the game without Battle Net, I simply use Wow.exe in the retail directory.

Hardware = AMD FX™-4300 Quad-Core Processor, 16GB DDR3 1600 RAM, GTX1050Ti 4GB
I get around 55-75 FPS on average.

To digress a bit…
Also, I cheated some- I bought a disk that came preformatted with Win7 so I shrunk the partition and added linux on the claimed space and set up dual boot. It allowed me to install WoW with windows and I just pointed lutris to the Win7 partition. I don’t like it, but it is handy for lots of stuff that really insist on windows.

Maybe all I needed to do was go complain on a forum and the problems magically disappear…well sort of, almost, I have still experienced relapses once or twice but it have been fixed by a fast relog both times. Unlike before were it would be more or less constant and when appearing be persistent.

Is it solved?..no I got no idea what coursed or are coursing these issues or if they are in fact gone now. It feels puzzling since I did reset. But I obviously do not have a clue.

The two most significant changes I have made so fare is executing with wow.exe in the retail folder and trying out DXVK 0.93.

I do believe that I am defaulted to Lutris Runtime enabled and preferring system libraries.

Lets digress by all means :slight_smile:

Ryzen 1600
16GB DDR4 2666MHz
GTX1050Ti 4GB

DXVK 0.93
Enable Esync

I am on arch and one of those awful gnome users. Having said that running games in fullscreen should maybe just perhaps disable compositing but in any case at the moment I am trying out gnome-flashback, for games, which basically seem to be old gnome with metacity.

I have no idea how to make useful statements on fps, I mean, where and how to make that measurement? In any event with my setup (i.e. current desktop, wine version) I would guess that the lowest fps are between 25-35 (that would be raids, lowest fps experienced outside raids would be for instance stormwind, new dalaran, with like 40 fps at times, depending) I would also say on average I get 55-75 fps.

All these fps feelings feel extremely subjective, at the same time, beside the obvious, namely the reason I started this thread, fps are one of the main reasons why can not get back into the game, oh and then the absolutely zero linux support rule from Blizzard.

This should surely be for a new thread, but hey, I think am going to look into how to use custom versions of wine with lutris too.

So I found the woe.

It suddenly dawned on me that this seemed to happen when I tapped out of the game, just as it was very difficult to alt-tab out in the first place. This was not much of a problem with gnome3 as it handles alt-tabbing very differently than gnome-flashback. So if this is solely related to the way gnome-flash back handles windows I do not know. I don’t feel like testing right now but what I can say for sure is that this did not happen pre-patch bfa 8.1 on gnome3.

Just to be clear this did also on occasion occur on startup.

Any who…that gave me something new to search for and it turns out to be Fullscreen-windowed-mode that cursed the issues. I would alt-tab out, get back in, and the UI would be behaving strange, like could not open bags for instance.

Graphics > Display > Display mode > Switch to windowed

That’s it!

Then switch back to Fullscreen (windowed).

ps There is, as I’m sure you all know, an alternative graphics setting that can be applied for raids and BG’s. Which I have not made use of but which would likely make the game more playable, at least for me.

Ok this may be it on my side as well. Although I permanently run in fullscreen (windowed); I do Alt Tab a lot.
I’ll have a closer look at it myself. And see if I can replicate the issue more scientifically.

The bug have not been around the last couple of days. Since this did happen without any addons whatsoever and on a fresh install I’m inclined to think that something somewhere was fixed. I can also say for sure that switching from fullscreen windowned to windowed would absolutely fix any UI problems immediately.

Also to report on performance.

No doubt addons can be very responsible for serious fps hits. I do have a few addons at the moment but none that, at least from what I have noticed, have any impact on my fps. Two addons that for sure gave me significant fps problems in large player scenarios was 1. VuhDo and 2. Shadowed Unit Frames both not updated for 8.1 tho.

Currently running with success.

wine-staging 4.0rc2-1
DXVK 0.94

This will give me steady average of ~30 fps in epic 80 players BGs and 25 man raids. This is on a low setting like 2 with view distance set to 6. But is it differently playable.

Other than that I get an easy average of 75 fps just about anywhere else. (excluded main cities ofc)

So if anyone got really bad fps and shuttering I would encourage you to first try to reset and disable all addons.

Lastly I’ll drop a link to wine-stagning because I found it interesting and useful so anyone reading this might just too.

Thanks for that link.
When I get some time, I’ll see what I can do with vkd3d and DX12
But for now I am still happy with my lutris setup.