[SOLVED] World of Warcraft Classic Unable to start up 3D Acceleration


The solution and further discussion regarding this issue can be found at DXVK’s official Github: https://github.com/doitsujin/dxvk

To sum, it can be fixed by altering the Vulkan ICD Loader option on System Options in Lutris and/or adding the Environment Variable DXVK_FILTER_DEVICE_NAME.

Hello to all.

I’ve been using Lutris + Wine to play World of Warcraft Classic for quite some time now, maybe around 5 months. During this time I only had minor issues quickly fixable. The game was working correctly, including the DXVK, Esync, graphics and stability.

This week I’ve noticed that I had a lot of packages to update and, among those, Mesa-Vulkan (from kisak-mesa PPA) and Wine staging. Update+Upgrade all done. All installed. Rebooted the system. But now a massage pops up when trying to open WoW via Lutris: “World of Warcraft Classic was Unable to start up 3D Acceleration”.

Already having the latest Lutris version installed, that’s what I’ve tried to do so far to try fixing it:

  1. Disabling DXVK on Lutris: by doing this the game opens but soon enough it crashed when trying to play on different maps;
  2. Using a different Wine version: lutris versions 5.1 to 6.4 with DXVK on. None worked.
  3. Using a different DXVK version: tried to use every previous versions available on Lutris, from versions 1.7L, 1.7.1L to 1.7.3L-03f11ba (the most recent version available on Lutris for me). None worked.
  4. Downloading/Updating DXVK to the latest version: downloaded versions 1.8 and 1.8.1 from the official Github and installed them on Lutris’ .local file path. Didn’t work.

I’ve looked on the internet for the same problem and found a couple of results, although none with a solution. Many suggesting to update Lutris, Wine, Kernel, but I have the most recent version avaiable of it all - and it still doesn’t work.

Here are the current versions of my system - all recently updated:

  • OS: Ubuntu 20.04
  • Kernel: 5.8.0-53-generic
  • Lutris:
  • Wine: 6.8 Staging
  • Mesa-Vulkan: 21.1.0 (kisak-mesa ppa / stable Mesa version)
  • DXKV: 1.7.3L-03f11ba (latest on Lutris) / 1.8.1 (latest on the official Github)
  • GPUs: AMD ATI Radeon R7 M260/M265 + Intel UHD Graphics 620

Follow as well the log from Lutris using -d command on terminal: https://paste.ubuntu.com/p/HjDK86rD6W/

Battle.net and other games via Lutris are running just fine. It updated WoW today with no issues, by the way (after the problem was already occurring). And I use no overlay (discord or whatever).

I’m getting kinda desperate because in a few weeks WoW TBC will come out and I’m afraid not to be able to enjoy it from day one. :frowning_face:

Is any one having the same issue and/or just happened to find a solution for it?

Any help is very much welcome!

Many thanks,


I had the exact same problem and I solved it by restarting my computer. In my case, my graphics card drivers were updated automatically and I tried running wow classic before restarting. Once I restarted I did not have the error anymore.

I’m using the latest version of Lutris on Ubuntu 18.04.

I hope this helps!