[SOLVED] Witcher 3 - Mouse hitting boundaries and stopping

Witcher 3
Ubuntu 19.04
Runner: Lutris 4.12.1 w. DXVK enabled

This is a weird issue that to the best of my knowledge is unique to The Witcher 3. It isn’t a crash and everything seems to be functioning perfectly except for the mouse, basically I noticed this when trying to spin Geralt round in circles a bunch but it looks like the mouse is stopping at the screen bounds. So you spin Geralt round twice to the right and you can’t move your mouse to the right any more, which means you have to spin left a few times before you can steer right again. Off the top of my head it looks like the mouse is being constrained by the screen despite the game being full screen and it being meant to directly capture mouse input.

This is probably a setting I just need to change, it’s not something I’ve ever seen in a vanilla WINE install so I was just wondering if I needed to change something in Lutris.

EDIT: The issue can be worked around by disabling the virtual desktop, removing this immediately resolves the issue.

1 Like

hey @gg86,
how do you disabled the virtual desktop?
cause I have the same behavior in Linux mint…