Back to the main site

[Solved] Witcher 3 don't work anymore after wine-staging upgrade


#1

Hello, two days ago there was upgrade on my Ubuntu 18.10. Nvidia drivers was upgraded to version 410.73. I have Dell Laptop with optimus graphics. Witcher 3 was working perfect on nvidia 396 and 410 drivers. Now I downgrade drivers to version 396 and try different wine versions but nothing helps. When I click game launcher my screen freezes and nothing happen. In terminal it looks like this:
terminal output

Edit. I noticed that when I login in Wayland session I have black screen instead of screen freeze.


#2

err: D3D11: CreateGeometryShaderWithStreamOutput:
Transform feedback not supoorted by device

Since you downgraded, your NVidia drivers shouldn’t support VK_EXT_transform_feedback, which is required in 0.90. Either pick a suitable version NVidia driver with that kind of support or downgrade dxvk to 0.82.

You can possibly verify if you have the extension by downloading vulkan-utils (apt) and running

vulkaninfo | grep VK_EXT_transform

If you want to check vulkaninfo works fine first, try

vulkaninfo | head

It is worth to mention some people say “don’t bother with whatever vulkan version shows up in vulkaninfo, it may not be accurate”

EDIT: info about suitable nvidia drivers for dxvk 0.90: https://github.com/doitsujin/dxvk/issues/695


#3

But it works great with 396.54 drivers and dxvk 0.90 before. Then I have upgrade to nvidia 410… and also work great and two days ago there was upgrade to nvidia 410.73 and also wine-staging 3.19 then W3 stop working.

Now I upgrade once again nvidia drivers to 410.73.

vulkaninfo | grep VK_EXT_transform                                                                                                                                                            
INTEL-MESA: warning: ../../../src/intel/vulkan/anv_device.c:1150: FINISHME: Implement pop-free point clipping
vulkaninfo: /build/vulkan-tools-ZnxIl9/vulkan-tools-1.1.82.0+dfsg1/vulkaninfo/vulkaninfo.c:1253: AppDumpSurfaceFormats: Assertion `!err' failed.
zsh: abort      vulkaninfo | 
zsh: exit 1     grep VK_EXT_transform

vulkaninfo | head                                                                                                                                                                
INTEL-MESA: warning: ../../../src/intel/vulkan/anv_device.c:1150: FINISHME: Implement pop-free point clipping
==========
VULKANINFO
==========

Vulkan Instance Version: 1.1.82

#4

Those vulkaninfo outputs seem very odd. It’s as if your drivers are bugged.

If you check the first line of the first command, it goes into /src/intel/vulkan. It’s probably trying to get stuff from your iGPU.

I now nothing about this and have no way to test, but maybe by adding an environment variable, you can “execute vulkaninfo” with your nvidia gpu?

DRI_PRIME=1 vulkaninfo | head

or something like that. (sorry if this doesn’t work).

Another thing, does any game work with Vulkan/DXVK at the moment? If not, it can point to a buggy driver install of some sorts. If they do, your issue may be specific from W3.


#5

It’s the same:

DRI_PRIME=1 vulkaninfo | head                                                                                                                                                                 
INTEL-MESA: warning: ../../../src/intel/vulkan/anv_device.c:1150: FINISHME: Implement pop-free point clipping
==========
VULKANINFO
==========
Vulkan Instance Version: 1.1.82

I don’t have any other game working with DXVK.


#6

Don’t use Wayland to game. Use 396.54.09 not 410. Stream output is only supported with 396 currently. You can get the ppa for it here:

https://launchpad.net/~graphics-drivers/+archive/ubuntu/dev


#7

Hi, I don’ t use wayland. I think it’s wine-staging 3.19. When I downgrade drivers to 396 game also don’t work. Now I restore my system with timeshift and W3 works perfect with winehq-staging 3.18, nvidia 410.66 and dxvk 0.90. Yesterday when I choose wine-staging 3.18 in lutris game don’t work with nvidia 396 or 410.73. I think that must be winehq-staging 3.18. I must block upgrade wine-staging somehow.

Edit. I block wine-staging upgrade and Witcher 3 works great even if I upgrade nvidia drivers. Thanks for Your help.


#8

Hello again.
Yesterday I have those upgrades on my Ubuntu:

accountsservice curl desktop-file-utils dmsetup gdm3 gedit gedit-common gir1.2-accountsservice-1.0 gir1.2-gdm-1.0 gir1.2-goa-1.0 gnome-control-center gnome-control-center-data gnome-control-center-faces gnome-initial-setup gnome-online-accounts initramfs-tools initramfs-tools-bin initramfs-tools-core libaccountsservice0 libc-bin libc-dev-bin libc6 libc6:i386 libc6-dbg libc6-dev libc6-i386 libcurl3-gnutls libcurl4 libdevmapper1.02.1 libgdm1 libgoa-1.0-0b libgoa-1.0-common libgoa-backend-1.0-1 libnvidia-cfg1-410 libnvidia-common-410 libnvidia-compute-410 libnvidia-compute-410:i386 libnvidia-decode-410 libnvidia-decode-410:i386 libnvidia-encode-410 libnvidia-encode-410:i386 libnvidia-fbc1-410 libnvidia-fbc1-410:i386 libnvidia-gl-410 libnvidia-gl-410:i386 libnvidia-ifr1-410 libnvidia-ifr1-410:i386 libxnvctrl0 locales multiarch-support nvidia-compute-utils-410 nvidia-dkms-410 nvidia-driver-410 nvidia-kernel-common-410 nvidia-kernel-source-410 nvidia-settings nvidia-utils-410 pop-gtk-theme pop-icon-theme python3-distupgrade ubuntu-release-upgrader-core ubuntu-release-upgrader-gtk wine-staging wine-staging-amd64 wine-staging-i386:i386 winehq-staging xserver-xorg-video-nvidia-410

I upgrade, then W3 stop working (I try many lutris >wine - dxvk combinations) - black screen after launch. When I hold wine-staging upgrade it don’t help. Game still don’t work. I think it’s nvidia driver 410.78.
Anyone have that problem?


#9

Nvidia (#267)
Recommended driver version: 396.54 or later
For Stream Output support, use 396.54. 09

From DXVK’s driver support section on Wiki.


#10

Drvier 410.73 works fine. New driver 410.78 that want to update make trouble. Can You tell me how to block nvidia drivers from upgrade?


#11

On ubuntu, you can tell apt to do like

apt install name-of-your-package=410.86

and it will try to downgrade that package into that version, if it exists


#12

Now I have only 2 drivers to choose on ubunut:

ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Dsv00001028sd000007FAbc03sc02i00
vendor : NVIDIA Corporation
model : GP107M [GeForce GTX 1050 Mobile]
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-415 - third-party free recommended
driver : xserver-xorg-video-nouveau - distro free builtin


#13

Those are the ‘most up to date’ versions they put available in their package manager thing, but if you pick a specific version like I mentioned, it will likely download it.

A lot of Ubuntu users are having the same issue, so I expect you can find help/guidance in the Ubuntu specific community, rather than on lutris. And it was probably not after wine-staging upgrade, as mentioned in your title (old thread), but after nvidia-driver update.


#14

I put this in terminal:
sudo apt-mark hold nvidia...
and upgrade other updates. Everything is OK now. I will not upgrade nvidia drivers until I finish Witcher 3 :slight_smile: