[Solved] Wine Steam Runner Not Installing (Ubuntu 18.04)

I can’t seem to get Wine Steam to install on my system. I have wine staging 3.12 installed through the lutris loaders but it always downloads the wine package again and then stops before it actually installs steam. Here’s what I get with running ‘lutris -d’. My log file only states that it is overwriting the existing wine download.

DEBUG 2018-08-07 12:15:44,964 [api]:Fetching game library
DEBUG 2018-08-07 12:15:44,997 [steam]:Watching Steam folder /home/user/.steam/steam/steamapps
DEBUG 2018-08-07 12:15:54,754 [runner]:Installing wine (version=None, downloader=None, callback=None)
INFO 2018-08-07 12:15:54,755 [runner]:Getting runner information for wine
DEBUG 2018-08-07 12:15:55,525 [runner]:Got 114 versions
Gtk-Message: 12:15:55.532: GtkDialog mapped without a transient parent. This is discouraged.
DEBUG 2018-08-07 12:15:55,533 [downloader]:Starting download of:

DEBUG 2018-08-07 12:21:29,136 [downloader]:Download finished
DEBUG 2018-08-07 12:21:29,198 [extract]:Extracting /home/user/.cache/lutris/wine-staging-3.12-x86_64.tar.gz to /home/user/.local/share/lutris/runners/wine/staging-3.12-x86_64
DEBUG 2018-08-07 12:21:31,245 [extract]:Moving element bin of archive
WARNING 2018-08-07 12:21:31,245 [extract]:Overwrite existing path /home/user/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin
DEBUG 2018-08-07 12:21:31,245 [system]:Merging /home/user/.local/share/lutris/runners/wine/staging-3.12-x86_64/.extract-fd70353f/staging-3.12-x86_64/bin into /home/user/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin
DEBUG 2018-08-07 12:21:31,245 [system]:Copying wrc
DEBUG 2018-08-07 12:21:31,246 [system]:Copying regedit
DEBUG 2018-08-07 12:21:31,246 [system]:Copying winefile
DEBUG 2018-08-07 12:21:31,246 [system]:Copying winemaker
DEBUG 2018-08-07 12:21:31,247 [system]:Copying notepad
DEBUG 2018-08-07 12:21:31,247 [system]:Copying winegcc
DEBUG 2018-08-07 12:21:31,247 [system]:Copying function_grep.pl
DEBUG 2018-08-07 12:21:31,247 [system]:Copying wineserver
DEBUG 2018-08-07 12:21:31,247 [system]:Copying widl
DEBUG 2018-08-07 12:21:31,248 [system]:Copying wine
DEBUG 2018-08-07 12:21:31,248 [system]:Copying wineconsole
DEBUG 2018-08-07 12:21:31,248 [system]:Copying wine64
DEBUG 2018-08-07 12:21:31,248 [system]:Copying regsvr32
DEBUG 2018-08-07 12:21:31,248 [system]:Copying winecfg
DEBUG 2018-08-07 12:21:31,248 [system]:Copying winecpp
DEBUG 2018-08-07 12:21:31,253 [system]:Copying msiexec
DEBUG 2018-08-07 12:21:31,253 [system]:Copying msidb
DEBUG 2018-08-07 12:21:31,253 [system]:Copying wmc
DEBUG 2018-08-07 12:21:31,254 [system]:Copying winepath
DEBUG 2018-08-07 12:21:31,254 [system]:Copying winebuild
DEBUG 2018-08-07 12:21:31,255 [system]:Copying wineboot
DEBUG 2018-08-07 12:21:31,255 [system]:Copying wine-preloader
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/runnersdialog.py”, line 166, in on_install_clicked
File “/usr/lib/python3/dist-packages/lutris/runners/runner.py”, line 317, in install
self.download_and_extract(url, **opts)
File “/usr/lib/python3/dist-packages/lutris/runners/runner.py”, line 339, in download_and_extract
File “/usr/lib/python3/dist-packages/lutris/runners/runner.py”, line 349, in extract
extract_archive(archive, dest, merge_single=merge_single)
File “/usr/lib/python3/dist-packages/lutris/util/extract.py”, line 80, in extract_archive
system.merge_folders(source_path, destination_path)
File “/usr/lib/python3/dist-packages/lutris/util/system.py”, line 236, in merge_folders
os.path.join(dst_abspath, filename))
File “/usr/lib/python3.6/shutil.py”, line 241, in copy
copyfile(src, dst, follow_symlinks=follow_symlinks)
File “/usr/lib/python3.6/shutil.py”, line 121, in copyfile
with open(dst, ‘wb’) as fdst:
OSError: [Errno 26] Text file busy: ‘/home/user/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine-preloader’

Did you install wine on your system besides in Lutris?

If you didn’t you’re likely missing dependencies

If you are missing dependencies then this won’t help.

Pretty sure these were the steps I took for steam launcher not launching.

I was also having issue installing steam games where the steam launcher wouldn’t launch. What I did was in lutris -> right click wine steam > run.

This installed only steam. After the complete install/update I then tried to use the install button for the game (on lutris.net) and it was able to launch steam and install the game. The game in question was divinity original sins II

I’ll try installing wine on my system. I guess I figured I would get a warning if I needed to install wine separately. I’ll see if I can get someone to add that warning to the download page atleast, I see it in the faq now.

I have the same issue on Solus Linux since a short while. Steam on wine with Wine staging 3.12 will just not launch. I have regular wine installed and all that. I already tried to remove everything and reinstall lutris, but no luck.

Installing wine on my system seems to have solved most of my issues. I did purge the lutris package and reinstall it first. I am having some minor font issues in the steam friends list and in steams browser but it can play games at least.