[solved - wine issue] Mint 19 'Tara' Xfce - lutris does not bring up gui

Fresh install of Mint, Wine, Lutris, etc. Invoking Lutris brings up no interface, but leaves a thread running.
Tried running it in terminal, got the output at end of this post. the /z directory didn’t exist so I created it. Output remained unchanged.

Thanks for your time and any help that occurs

USER@computername:~$ lutris
ERROR 2018-12-07 08:19:15,495 [wineregistry]:Unable to read link for /home/USER/.wine/dosdevices/z:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/application.py”, line 190, in do_activate
self.window = LutrisWindow(application=self)
File “/usr/lib/python3/dist-packages/lutris/gui/lutriswindow.py”, line 148, in init
self.sidebar_treeview = SidebarTreeView()
File “/usr/lib/python3/dist-packages/lutris/gui/sidebar.py”, line 75, in init
File “/usr/lib/python3/dist-packages/lutris/gui/sidebar.py”, line 119, in update
self.installed_runners = [runner.name for runner in runners.get_installed()]
File “/usr/lib/python3/dist-packages/lutris/runners/init.py”, line 69, in get_installed
if runner.is_installed():
File “/usr/lib/python3/dist-packages/lutris/runners/winesteam.py”, line 313, in is_installed
steam_path = self.get_steam_path()
File “/usr/lib/python3/dist-packages/lutris/runners/winesteam.py”, line 278, in get_steam_path
File “/usr/lib/python3/dist-packages/lutris/util/system.py”, line 295, in fix_path_case
if os.path.exists(path):
File “/usr/lib/python3.6/genericpath.py”, line 19, in exists
TypeError: stat: path should be string, bytes, os.PathLike or integer, not NoneType
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/lutris/gui/application.py”, line 323, in do_command_line
AttributeError: ‘NoneType’ object has no attribute ‘present’

Also a Lutris user on LM 19. I don’t know why is it trying to read ~/.wine as its first thing… but try installing Wine staging(?)

Then run it once to populate ~/.wine … typing this command in a terminal anywhere

If you want to be more strict about it
WINEPREFIX=~/.wine winecfg

If you did absolutely nothing with Lutris before, it shouldn’t have Wine as a dependency to START UP, as far as I know. If these steps solve your problem, it’s a bug that needs to be fixed.

1 Like

Probably should have specified that I reused my existing userspace, so some previous config is almost certainly in place.

Went to try out winecfg, and it fails too. So it looks like I somehow borked up my wine install (did use the winehq instructions).

Thanks for the assist.

edit - wine was choking on the previously existing .wine directory, which is new behavior to me.
deleted .wine, ran winecfg, and we’re in business again.

For anyone with the same problem - if winecfg spits out a bunch of ‘can’t create < directory >’, try deleting the .wine directory and running it again.

you dont need to do anything you have to

LC_ALL=C lutris

lauch it using LC_ALL=C argument in terminal. :slight_smile: