Back to the main site

[SOLVED] Wine config not saving


#1

I’m running Diablo 2 windowed in an emulated desktop so I can increase the size of the game window. This is working just fine.

However, Wine in Lutris does not save the setting i made for emulated desktop. I have to configure this every time I play.

The game is playing fine with wine staging 3.7 in Lutris otherwise.

OS: Manjaro Linux x86_64
Host: VPCEB3Z1E C606S9RE
Kernel: 4.14.71-1-MANJARO
Uptime: 17 hours, 17 mins
Packages: 1260 (pacman), 2 (flatpak)
Shell: bash 4.4.23
Resolution: 1920x1080
DE: Xfce
Theme: Vertex-Maia [GTK2], Adwaita [GTK3]
Icons: Vertex-Maia [GTK2], Adwaita [GTK3]
Terminal: xfce4-terminal
Terminal Font: Monospace 12
CPU: Intel i5 M 460 (4) @ 2.534GHz
GPU: AMD ATI Mobility Radeon HD 5650/5750
Memory: 2859MiB / 7834MiB


#2

The first thing I would look into is if Lutris has permission to write in your Games folder. I’m running on the default ~/Games/ folder and it can definitely write config files there…

Just to confirm, you’re able to right click configure in Lutris’ menu and when you do it again, settings reset?


#3

Since I installed Diablo 2 through Lutris in the default ~/Games/ folder it should have permission, right?

Yes, right click on Diablo 2 in Lutris --> Wine configuration --> Graphics --> check Emulate a desktop and set to 1280 x 960 --> apply. When I start the game next time it’s unchecked and reset to 800 x 600.


#4

Run lutris with

lutris -d

and give us what your terminal outputs after closing the winecfg interface. If you want to put it in a file (with Lutris startup stuff and etc.) do

lutris -d > logfile_for_lutris.txt

Also, just to make sure, does this also happen in other games?


#5

Lutris ignores virtual desktop set from winecfg. Use the option under runner options.


#6

That’s really confusing. But thanks for info!


#7

Please edit the title with [SOLVED] in the beginning.

The “rule” we learn here is that Lutris will handle everything for the environment and you may make small tweaks in the Staging tab, for example.


#8

OK. Working fine now. Thanks guys.