Back to the main site

[SOLVED] Wine: Bad EXE format


#1

Hello, everyone! New user and first time poster here.

I’m running Lutris in Arch and I’m just sampling it here and there so far.

I’ve gotten one Steam Windows game to install and run with no issues, one Sega Genesis game to run with no issues, but I’m trying to install a Windows game without Steam and that’s where my problem lies.

I’m at work right now, so I won’t be able to pull up exact errors at the moment. When I’m on lunch, I’ll run home and see what I can do.

The Windows game in question is Guild Wars 2 (64-bit client). When I open Lutris through the terminal and try to launch GW2, I see an error saying that it’s a bad EXE format. So I set the runner’s WINEARCH/WINEPREFIX (like said, not home, so I can’t tell right now) to 64, and then it says that I only have the 32 bit version of Wine installed. However, the runner I’m using is the latest staging for 64 bit.

As of the moment I am able to get the 32-bit installer to work just fine. In fact it’s installing while I’m away from home.

What can I do to force Lutris to use the 64 bit prefix? Should I uninstall my non-Lutris Wine?

Thank you!

EDIT I’ve forgotten to mention that when it says I only have the 32-bit version of Wine installed, it points to /home/shakkol/.wine.

EDIT EDIT I renamed my /home's /.wine to /.wineX to see if it would effect anything and Lutris created a new one. I deleted /.wine and /.wineX and just selected the 64-bit installer and set the prefix architecture to 64 and it worked.

Now, I’m going to install this and add a ton of applications to Lutris’s supported games as I get them working. And a HUGE thank you to the devs for this. I don’t have anywhere near as many headaches with this app that I did with one I relied on for so long…

So for anyone else having this problem, just delete your /.wine folder.


#2

What can I do to force Lutris to use the 64 bit prefix?

use a 64bit wine version, and set the Prefix architecture in the Game options tab.

Should I uninstall my non-Lutris Wine?

nope, or rather doesn’t matter

I only have the 32-bit version of Wine installed, it points to /home/shakkol/.wine

that’s a wineprefix, not a wine version though. I suspect you tried to import an existing wineprefix with multiple apps into lutris, which usually isn’t a good idea. the whole idea of having a ~/.wine (which wine does by default, sadly) is wrong imho, because there’s a great chance over time redist stuff from one installer breaks dependencies of another app and stuff like that.

So for anyone else having this problem, just delete your /.wine folder.

please don’t.

  1. you shouldn’t use ~/.wine to collect all the apps into one prefix anyway
  2. telling people to nuke a whole bunch of possibly important data without telling them why and that they’re actually doing this isn’t the best idea
  3. you could have just done it right and stopped using ~/.wine and install it correctly through lutris because that’s what’s it meant for anyway.

so yeah if you just used lutris and wine right there’d be no reason to mess around with that folder anyway, and telling people “if you have this problem which might have any number of causes just delete a folder which might contain data important to you without you even realizing” just makes no sense.


#3

Thank you for your reply. If it helps, I left Lutris to its default settings when I installed it. As far as to why there was a wine folder in my home directory, I’m uncertain. I did check the contents and it didn’t have anything I was working on which is why I was comfortable nuking it.

That’s what I was doing, and Lutris/Wine/Whatever insisted on using a 32-bit prefix. I was very specific to set the prefix to 64-bit, set my Wine version to 3.3.1 x86_64 and my terminal output was still saying that I was trying to launch a 64-bit program in a 32-bit environment.

I wasn’t. I had everything that I installed through Lutris install to a bigger “game drive” because I intend to install a lot.

When I went to install the application, it asked where the installer was, which I pointed to another drive. At no point at any time while I was using Lutris did I ever command the program to install to a default wine prefix directory.

Well, when I leave the Lutris installation to its defaults and I select an installer for a Windows program in a completely different drive altogether, I’m not sure what I could have done that would have directed Lutris, GW2, or what have you to install to /.wine. If I’m unsure about something, I don’t go around mindlessly changing settings.

If it helps, at this point I’ve gotten several games installed with no problems now. Some have a few problems, but they’re probably library issues (No sound at all from Dark Souls, etc.) and nothing to do with any incorrect Wine prefixes.


#4

ok that’s very strange. never saw that happen before 0.o

yeah you shouldn’t do that either. one prefix per game is the best to do.

actually that sounds like you have got a buggy version of lutris and/or the installer script, it shouldn’t touch ~/.wine at all unless you tell it to.

yeah that really seems to be like one specific strange bug with the installer or lutris (that I have never encountered on the current versions) or you somehow managed to get those wineprefixed symlinked into each other but I doubt that. usually the only reason for ~/.wine to even exist is double clicking a .exe file from your file manager so it runs with wine default settings (which usually are wrong :P) instead of in lutris…


#5

It could be buggy. I’m not really certain as to which bugs may be present. But I do like learning the environment, and Lutris does just make that easier on me in the end. :slight_smile:


#6

yeah it’s really great imo. also the way the installer scripts are done makes stuff very easy :slight_smile: