[SOLVED] What happened to wine runner lutris-fshack-5.7-x86_64? can't start WoW after upgrading to Kubuntu 20.04, only Battle.net launcher

Hey everybody,
admittedly this is a shot in the dark. But I’m stumped…

At the end of last year I bought a new computer with an NVIDIA graphics card, installed Kubuntu 19.10 (after years of using Debian stable), Lutris and World of Warcraft and was extremely happy with everything as it all just worked. Like, out of the box, iirc.

Then there was an issue after a WoW update where I’d get frequent error #132 crashes, and switching to a different wine version fixed it for me, after a few tries – I had 4.x before, and checking my old backup, the one I’d been using for the past few months was lutris-fshack-5.7-x86_64. I also seem to remember that the fshack bit was somehow important (but my memory may deceive me here).

Anyway, after I had some unrelated system issues I formatted the ssd drive that holds all my system data and installed Kubuntu 20.04, so an upgrade while I was at it. This proved to really go very smoothly since my home directory along with my games directory containing World of Warcraft and all the important config bits sat safely on a separate disk, and for the most part, everything is back to fully functional again.

World of Warcraft, however, will NOT start no matter what I do. The Battlenet launcher always works, no problem, and then when I click play, I’ll get an error #132 crash in 0.5 to ~3 seconds.

What I’ve tried so far:

  1. After 20.04 was set up, I installed Lutris and WineHQ-stable, both in the documented way. (I checked and had WineHQ-stable before.)
  2. My old configs were found and used, I started the game, the Battlenet launcher came up alright, I clicked play >> error #132.
  3. Remembering the issue after the last WoW update, I went to change the wine runner. I then noticed that the one from my old configs – lutris-fshack-5.7-x86_64 – was not available at all, so I thought that might be it. Downloaded the last three or so and tried them all – same problem. Dito for using the system version and the WineHQ version.
  4. I then razed all the lutris and wine packages and renamed the config folders, reinstalled wine in the staging version, then reinstalled lutris, still couldn’t find the old runner version so I used the latest one available (lutris-5.7-8).
  5. Started the game, which prompted me to reinstall the Battlenet launcher, which I did. Then had a popup saying it found my World of Warcraft installation and whether I wanted to use that, which I confirmed. Clicked play in the Battlenet launcher – #132 crash.
  6. Installed wine-devel, which deinstalled wine-staging, the issue remains.

At this point I do feel a bit stuck. What else could I try? I would rather avoid reinstalling the whole game as it took me a whole night and half a day to download the first time around… I’d only do that if I was fairly confident there’s a chance that would fix the problem, and right now I don’t really think so. (Change my mind if you think differently!) The only tiny thing I noticed is that newer wine versions seem to take a second or two longer to crash – not sure if that’s significant in any way though.

I also feel this is probably not a Lutris problem :neutral_face: however, I was wondering where that working wine runner version went. Can anybody perhaps tell me something about this? And any other ideas are very welcome too, of course!

One last thought: I just tried again and generated a humongously long log, however most of that seems to consist of two or three repeating fixme notes. You can check out the whole thing here, what caught my eye is the following line:

018b:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

I then installed the winbind package which seems to have fixed this error notice in the logs, however WoW still won’t start. :frowning:

Thank you for your time and thoughts!

I found it.

The easiest, simplest solution ever: I changed the Windows version in the Wine configuration dialogue from Windows 7 to Windows 10. – Gonna write that one down!!

And now I can play World of Warcraft again :smile:

1 Like