Back to the main site

SOLVED - Warframe Stuttering

After the recent update to Warframe it has been stuttering hard.

warframe_stutter

Anyone else experiencing this? Any possible fixes or avenues of possible diagnosis. Sorry, Lutris newb.

I’m on AMD+dxvk0.70 and nothing is stuttery. All graphical settings are on minimum. I heard they have a new nvidia driver, maybe that helps? Try changing the in-game settings first

Tried a reinstall of Warframe tonight as well as all minimum, as @dan1lo_bc suggested, still stuttering.

Try not using vsync, but a frame limit ingame?

And well, what desktop are you using, compositor in there might be messing up frametimings.

2 Likes

Well… crap.

I did some DE bouncing the other night and XFCE was shaping up to be awesome. Booted back into MATE tonight, Waframe’s not stuttering. :frowning:

Waframe_Nostutter

@Dox - You were spot on. For some reason the compositor that MATE uses (Marco?) didn’t have a problem with Warframe being on VSync. I rebooted back into XFCE (to ensure compositor switch), turned off VSync, Warframe is perfectly smooth. If I set it to frame limit to 60FPS (same as if I did VSync), still smooth.

Thanks much!

You can turn off XFCE compositor and use Compton, perhaps it works better.

Just a generic rule of thumb I found, a few games I tested don’t behave right with VSync, so I end up simply disabling it and living with possible screen tearing. The FPS gain, although, makes this almos unnoticeable in, for example, Diablo 3

If you have nvidia, just use ForceCompositionPipeline. It means no tearing. And then just cap the game to your monitor refresh rate. (for blizzard games I usually set it to 62 so it is above refresh rate, displaycapped = 70 for OW).

If you can cap it using outside sources, I think it does the job fine. On AMD over here, I found out having a few games capped on FPS had a slight performance drop. Diablo would play 45~50 instead of 60+ (capped on 60) and Heroes of the Storm had a similar behaviour.

This may vary AMD <-> NVidia

https://eu.battle.net/support/en/article/32248

For Diablo / WoW I suggest not setting 60, but slightly above that.

1 Like

I just wanted to mention my Warframe settings changed. Either DXVK or Mesa (or both?) updated and now VSYNC ON makes the game run way smoother and pleasantly.

Everything else is still on minimum, “Just in case”

Do you think this could be my problem with d3? It’s unplayable on 64 bit but runs playable if I tick the use 32 bit version in battle net game options

Create a new post with your issues - Battle.net and Warframe are very different in how they work under Lutris. Make sure to include info on your hardware and drivers (Mesa version, kernel) etc in the post.