[SOLVED] Warframe Not Using Dedicated Graphics on Hybrid Laptop


I’m trying to run the standalone (i.e. non-Steam) version of Warframe. The game installs and runs, but performance is bad and choppy to the point of being unplayable, even on the lowest settings. I’m wondering if this is to do with the fact that the game isn’t using my laptop’s dedicated graphics card, but the integrated one:

I’n the game’s system options in Lutris I’ve checked “Use PRIME”, but that isn’t making Warframe use the AMD GPU, although DRI_PRIME=1 should work judging from the output of glxinfo:

$ glxinfo | grep “OpenGL renderer”
OpenGL renderer string: Mesa DRI Intel® HD Graphics 520 (Skylake GT2)
$ DRI_PRIME=1 glxinfo | grep “OpenGL renderer”
OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 4.14.78-1-MANJARO, LLVM 7.0.0)

In case it’ll help, here’s the output of neofetch with my system information:

OS: Manjaro Linux x86_64
Host: 80S7 Lenovo YOGA 510-14ISK
Kernel: 4.14.78-1-MANJARO
Uptime: 3 hours, 42 mins
Packages: 1336 (pacman)
Shell: bash 4.4.23
Resolution: 1920x1080
WM: KWin
Theme: Breath [KDE], Breath [GTK2/3]
Icons: breath [KDE], breath [GTK2/3]
Terminal: konsole
Terminal Font: Noto Mono
CPU: Intel i5-6200U (4) @ 2.
GPU: Intel Skylake GT2 [HD Graphics 520]
AMD ATI Radeon HD 8670A/8670M/
Memory: 3351MiB / 7833MiB

Thanks in advance for your help!

I’ve solved the issue! The problem wasn’t with Lutris or Warframe at all, but rather with my graphics card drivers. The default radeon driver did not work with Vulkan, which is why anything running on Vulkan would skip the card and use the integrated one instead.

If anyone comes across this issue with AMD hybrid graphics in the future, here’s what I did:

  1. I switched from the radeon to the amdgpu driver by blacklisting the radeon kernel module based on the instructions on the Arch wiki. Basically you need to create a .conf file in /etc/modprobe.d that contains the line: blacklist radeon

  2. I installed the package amdgpu-experimental. Without it, there were problems with using the dedicated card.

  3. I uninstalled the packages amdvlk and lib32amdvlk (I had previously installed them trying to see if they would fix the problem. They didn’t fix it). With these, Warframe and other programmes would load correctly with the dedicated graphics card, but wouldn’t display properly (just lots of horizontal coloured lines). Just vulkan-radeon and lib32-vulkan-radeon were enough for everything to work.

I hope this helps anyone else with this issue!


I was going to tell you the same thing, for me I use this guide:

i know is that 3 years ago, but solved my problems with Xorg Server!
thanks a lot!