Back to the main site

[SOLVED] VULKAN_NOT_FOUND despite all amdgpu vulkan packages being installed

I had been running Lutris with an RX 480 GPU with basically no issues for a while. For about a month I switched to a borrowed GTX 1060 to do run some CUDA specific tasks and had Lutris games running fine with that GPU as well. I have switched back to my RX 480 and now when I try to launch a game (GTA V via Epic in this case) I’m getting an error about vulkan not being installed. I have run the suggested command for my system (Arch Linux) and all packages were already installed.

Is anyone aware of anything that might have changed in the past month or two to affect this? Did I maybe miss something when switching back from nvidia to amdgpu? Any suggestions for further troubleshooting this?

As seems to be tradition for me, I solved if as soon as I posted my problem in a forum. :slight_smile:

I found export VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json in my .profile. Commenting that out and rebooting, all seems to be working again.