[SOLVED] Unable to Start or Install any games

I can’t install or run any game, the error message I get leads me to believe it’s a problem with my python installation. This error does not appear on any of my other python programs so I have come here for help. If this is not the place to be asking for help for this problem please let me know where to go instead.

Whenever I install or run any games I get this error:

Fatal Python error: init_sys_streams: can't initialize sys standard streams
Traceback (most recent call last):
  File "/usr/lib/python3.8/io.py", line 54, in <module>
ImportError: cannot import name 'open_code' from 'io' (unknown location)

This did not happen before, I don’t know when this started happening, what caused it to happen, or even begin how to fix it.

Lutris issue report file
Lutris -d output

Thank you for your help

Looks like a Python interpreter version issue.

But open_code is part of Python 3.8.


I always paste the error message in a search engine to see i I can find any other users who reported the error. I found a user who reported the same problem. See here on Stackoverflow:

Question is: is your issue the same? A version check can be done as follows:

python --version

And those ignored errors in your log are strange too. I would begin with checking what Python versions exist on the system and which are actually used.

It looks like I might be having a similar issue
When I run python --version it shows a version of python 3.8,
but when I run python3 --version it shows a version of python 3.7
Python 3.8 has a couple dependents according to my package manager but Python 3.7 doesn’t seem to be handled through my package manager at all.

Which distro are you two using?

I’m the same person, I meant that I was having a similar issue as the guy in the post you linked.
I’m running Arch Linux.

Oops. :sleeping:

You could look for an installed package called python37 other versions are often packaged like this to make it easy to install them side by side.

I’ve done that and as far as I can tell it isn’t installed under the AUR package. At least, it hasn’t been the way I would traditionally do it.

You are using pacman right?

What does a quey like this tell you?

pacman -Q | grep python

This is the output I get

Looks ok.

The error mentions Python 3.8 so why isn’t it there…

The only thing I can think of is a reinstall command:

pacman -S python python2

Isn’t that python 3.8 right there at the top?

I fixed the issue.
At some point I managed to an altinstall of Python 3.7 from source. I removed it by hand and lutris isn’t having any more issues.

Yay! Good to hear! :+1: