Back to the main site

[Solved] Unable to launch wine steam


#1

I’m unable to launch wine steam it crashes on launch and when i disable lutris runtime it works fine but i have no text on any of the windows.

beatrix@pop-os:~$ lutris -d
INFO 2018-07-12 12:07:44,666 [lutriswindow]:Connected to lutris.net as Beatrix
DEBUG 2018-07-12 12:07:44,680 [api]:Fetching game library
DEBUG 2018-07-12 12:07:44,724 [steam]:Watching Steam folder /home/beatrix/.steam/steam/steamapps
DEBUG 2018-07-12 12:07:44,724 [steam]:Watching Steam folder /home/beatrix/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files (x86)/Steam/steamapps
DEBUG 2018-07-12 12:07:52,655 [thread]:Command env: LUTRIS_RUNTIME ="" DRI_PRIME=“0” STEAM_RUNTIME="/home/beatrix/.local/share/lutris/runtime/steam" LD_LIBRARY_PATH="/usr/lib:/usr/lib32:/home/beatrix/.local/share/lutris/runtime/lib32:/home/beatrix/.local/share/lutris/runtime/steam/i386/lib/i386-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/i386/lib:/home/beatrix/.local/share/lutris/runtime/steam/i386/usr/lib/i386-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/i386/usr/lib:/home/beatrix/.local/share/lutris/runtime/lib64:/home/beatrix/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/amd64/lib:/home/beatrix/.local/share/lutris/runtime/steam/amd64/usr/lib/x86_64-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/amd64/usr/lib:$LD_LIBRARY_PATH" WINEDEBUG="-all" WINEARCH=“win64” WINE="/home/beatrix/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine" WINEPREFIX="/home/beatrix/.local/share/lutris/runners/winesteam/prefix64"
DEBUG 2018-07-12 12:07:52,655 [thread]:Running command: “/home/beatrix/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine” “/home/beatrix/.local/share/lutris/runners/winesteam/prefix64/drive_c/Program Files (x86)/Steam/Steam.exe” “-no-cef-sandbox”
DEBUG 2018-07-12 12:07:52,655 [thread]:Storing environment variable LUTRIS_RUNTIME to
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable DRI_PRIME to 0
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable STEAM_RUNTIME to /home/beatrix/.local/share/lutris/runtime/steam
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable LD_LIBRARY_PATH to /usr/lib:/usr/lib32:/home/beatrix/.local/share/lutris/runtime/lib32:/home/beatrix/.local/share/lutris/runtime/steam/i386/lib/i386-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/i386/lib:/home/beatrix/.local/share/lutris/runtime/steam/i386/usr/lib/i386-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/i386/usr/lib:/home/beatrix/.local/share/lutris/runtime/lib64:/home/beatrix/.local/share/lutris/runtime/steam/amd64/lib/x86_64-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/amd64/lib:/home/beatrix/.local/share/lutris/runtime/steam/amd64/usr/lib/x86_64-linux-gnu:/home/beatrix/.local/share/lutris/runtime/steam/amd64/usr/lib:$LD_LIBRARY_PATH
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable WINEDEBUG to -all
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable WINEARCH to win64
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable WINE to /home/beatrix/.local/share/lutris/runners/wine/staging-3.12-x86_64/bin/wine
DEBUG 2018-07-12 12:07:52,656 [thread]:Storing environment variable WINEPREFIX to /home/beatrix/.local/share/lutris/runners/winesteam/prefix64
ILocalize::AddFile() failed to load file “public/steambootstrapper_english.txt”.
[2018-07-12 12:08:10] Startup - updater built Jun 8 2018 15:25:12
Looks like steam didn’t shutdown cleanly, scheduling immediate update check
[2018-07-12 12:08:10] Checking for update on startup
[2018-07-12 12:08:10] Checking for available update…
[2018-07-12 12:08:17] Download skipped: /client/steam_client_win32 version 1528497815, installed version 1528497815
[2018-07-12 12:08:17] Nothing to do
[2018-07-12 12:08:17] Verifying installation…
[2018-07-12 12:08:17] Performing checksum verification of executable files
[2018-07-12 12:08:20] Verification complete
IPC client is in my process, could/should be using an in-process pipe.[0712/120823.041:INFO:crash_reporting.cc(215)] Crash reporting enabled for process: browser
[0712/120823.182:ERROR:network_change_notifier_win.cc(157)] WSALookupServiceBegin failed with: 8
[0712/120823.349:ERROR:gpu_process_transport_factory.cc(1029)] Lost UI shared context.
ALSA lib conf.c:3357:(snd_config_hooks_call) ALSA lib conf.c:3357:(snd_config_hooks_call) Cannot open shared library libasound_module_conf_pulse.soCannot open shared library libasound_module_conf_pulse.so

ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm_dsnoop.c:606:(snd_pcm_dsnoop_open) unable to open slave
ALSA lib pcm_dsnoop.c:606:(snd_pcm_dsnoop_open) unable to open slave
[2018-07-12 12:08:25] Background update loop checking for update. . .
[2018-07-12 12:08:25] Checking for available update…
[2018-07-12 12:08:25] Download skipped by HTTP 304 Not Modified
[2018-07-12 12:08:25] Nothing to do
Setting breakpad minidump AppID = 769
Steam_SetMinidumpSteamID: Caching Steam ID: 76561198122993997 [API loaded no]
Refresh rate: 0
Refresh rate: 0
Refresh rate: 0
[0712/120833.232:INFO:crash_reporting.cc(215)] Crash reporting enabled for process: renderer
[0712/120833.322:INFO:crash_reporting.cc(215)] Crash reporting enabled for process: gpu-process
Refresh rate: 0
Refresh rate: 0
Refresh rate: 0


#2

Nevermind installing the lastest wine staging from winehq website fix it. guess it was some dependence’s i was missing.


#3

Friendly reminder to anyone who sees this thread: always install winehq-staging on your system to get all the dependencies going.