[Solved] Ubisoft Connect - Unable to download because download freeze


I am a new user of Lutris and I tried to install Ubisoft Connect. I clicked install (the first option on the list) and Lutris started to download software. During download process the download freezes.

Here is screenshot:

The download process freeze on this line:

“Downloading https://web.archive.org/web/2000/https://github.com/pushcx/corefonts/raw/master/arial32.exe to /home/eccololo/.var/app/net.lutris.Lutris/cache/winetricks/corefonts”.

Can I ask for support in solving that problem?

Thanks :slightly_smiling_face:

close lutris
Under the ~/.var/app/net.lutris.Lutris folder there will somewhere be a folder called winetricks
open this folder in terminal and run:
./winetricks --self-update
try again.
If it fails again, note the source of the file and destination per your image and manually copy the files erroring from the web source to the local destination


Thank you for your help.

I updated Wine to the newest version and now when I install Ubisoft Connect I get this:

The window froze and installation was not continued.

What should I do?

This is an issue with Lutris downloading the needed exe file - If you can find the exe referenced, when you run the installer instead of using the download option default, select file from the drop down and point to UbisoftConnectInstaller.exe file you downloaded


Thank you for your help but I don’t understand what you are writing to me and what should I do.

Could you write to me what should I do step by step, please.

Thanks :slightly_smiling_face:.

In the image you posted it has a file called UbisoftConnectInstaller.exe - download this file in a browser.

Run the Ubisoft connect installer in lutris and where it says download, there is a down arrow - click the down arrow and select file (I am on a phone not sure 100%) - - click the three dots and find the Ubisoftconnect installer exe file you downloaded then continue to install using the local file

Ok, thanks. Now I understand. I will do that today, later and report what are the outcomes.

Thank you again :slightly_smiling_face:.

1 Like


Ubisoft successfully installed from a .exe file but I don’t see any games in Lutris. I remember I had a few games in my Ubisoft account like Assassin’s Creed (story in UK version) but as I checked in the Ubisoft web app I have info that I don’t have any games yet.

I would like to add to my Ubisoft Account XDefiant game (it is free) but when I click to add it either the Ubisoft Connect installer is downloading or the app wants to open on my system and nothing happens:

How can I add the XDefiant game to my Ubisoft account so that I can see it in Lutris, install it, and play it?

Thanks :slightly_smiling_face:

That one I am not sure on, I have it in my account, it downloads but you need some dll overrides to make it run - I would google that - IIRC there is a youtube guide

Ok, thank you OJ1. I will do Google research :+1:.