[SOLVED] Ubisoft Connect suddenly stopped working

Can’t load game luncher ubisoft-connect: I was playing Assassin’s Creed: Valhalla and had to stop playing for a few minutes, so i stopped the game and closed Lutris. Next time I tried Loading Lutris + Ubisoft Connect, Lutris loads but Ubisoft connect just hangs, no loading, no blackscreen nothing. This was without any reboot or system update.


lutris -d > ~/Transferências/lutrislog.txt (running lutris an lunching ubisoft connect)

I’m using Arch
Can anyone help?

i guess you running the game in Wine make sure your wine is updated also try to reinstall Wine or WineHQ depending on wish one you use I use both and I have noticed that sometimes WineHQ gets uninstalled for some reason maybe because of the conflict with each other idk but check that. also, did you use this Assassin's Creed Valhalla - Lutris when installing the game or just via the launcher if via the launcher I would recommend using the link.

i have wine-staging (6.23) installed but i rarely use the system wine, i use the lutris/steam/ge builds. I usually would install via ubisoft launcher, and maybe that was my mistake, i tried to install anno in the same bottle, and maybe that broke something. I think i still have something broken in my system since some games are working others are not. I suspect winetricks did one of his tricks… I can’t even install ubisoft, the Lutris installer hangs or stays 30mn trying to install some component…
It’s currently installing, that’s already good news, although it’s f… 100GB it will take 1 hour…
Thanks for your attention!

How does that work? you install it and use the steam (Steam for Windows game) to launce it with Steam Proton??. i have not really tried it that way I normally use Wine if I don’t use steam to install it with.

Lutris detects installed patched wine builds inside steam. plus you can download wine GE builds. plus you can use one of the built for Lutris.

it’s broken… installing the lutris recipes Ubisoft Connect and Assassin’s creed: valhalla do not work for me right now…

lutris -d ends with munmap_chunk(): invalid pointer

i don’t even own the game so I can’t test it have you tried to open it in Wine.

I found the problem… it was in my side as i suspected… after a lot of searching i stumbled upon the command vulkaninfo --summary, and it was giving me a familiar error: free(): invalid pointer
I had two implementations of vulkan installed, the mesa (RADV) and the amd implementations, and my system was loading the amd one, which was broken in Arch. I removed it and vulkaninfo --summary and games start working again. i could also lunched the game using the environment variables:


hope this helps someone and thanks for the “attention”!!


nice to know.

1 Like