[Solved] Total War Warhammer 2 (Windows version) trouble

Hi guys. I’m currently having trouble running Total War Warhammer 2. Someone must be thinking that “It already has Linux support!” which is correct, but the thing here is that I want to play the multiplayer, and on Linux+Mac platforms the multiplayer is practically dead. I have noticed that many have this game working on Lutris so I thought someone could be able to assist me here.

The problem is, that after I’ve installed wine steam, configured it, and installed the Windows version through Lutris’ install script: when I press the play button, literally nothing happens. The configuration I used here was using Wine staging 4.4, DXVK 1.0.1, and Lutris runtime was disabled. I also installed the game also without the Lutris install script, through Wine Steam. There the game was actually running, but after the loading/splash screen, I couldn’t see anythingbut black and the cursor, I could hear the cinematic and main menu sounds though. I’m not quite sure which way I should run the game, however it doesn’t work properly in either way.

I’m running on Linux Mint 19.1 with Cinnamon 4.0.9. I have an Intel Core i7 CPU and an NVIDIA GTX GeForce 980 with the ubuntu NVIDIA driver 418.43.

The more detailed reports/logs/debugs can be found here:
Lutris game log: https://paste.ubuntu.com/p/WQ6dCkxvWd/
Info from lutris -d: https://paste.ubuntu.com/p/ptW5h4ShYK/

And since I can’t post more than two links I’ll paste the openGL stuff here:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 980/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 418.43
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 418.43
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 418.43
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

003c:err:vulkan:wine_vk_init Failed to load vulkan library
003c:err:vulkan:wine_vk_init Failed to load Wine graphics driver supporting Vulkan.
003c:err:module:find_forwarded_export module not found for forward 'winevulkan.wine_vkGetInstanceProcAddr' used by L"C:\\windows\\system32\\vulkan-1.dll"

00f7:err:wincodecs:PngDecoder_CreateInstance Failed reading PNG because unable to find libpng12.so.0

Follow this and also make sure the “Disable Lutris Runtime” isn’t ticked on:




Nice, thanks a lot, this did the trick and the game runs smoothly. It could be that I was running the wine version from the xenial repository, not the bionic one since I recently updated from Mint 18 to 19. So completely reinstalling wine helped.