Back to the main site

[SOLVED] The Sims 4 "ts4_x64.exe not responding"

Greetings,

Final Edit: After further testing this morning, I managed to fix it. I started switching some options on and off like Anti-Cheat, BattleEye, Fsync and Esync, BUT, found out that ENABLING dgvoodoo2 made it work. It’s weird because I never had it enabled before the Pop_OS! update, not sure if it messed up some files I am missing now or something. Not sure if it’s a good fix either, it says dgvoodoo2 works only for 32-bit apps, which is weird because my Sims 4 is 64-bit. Either way, that did it for now.

Edit: My game works if I run it through the terminal “wine TS4_x64.exe”, but not through Lutris.

Lutris -d logs: Started initial process 9848 from /home/caferino/.local/share/lutris/runners/win - Pastebin.com

I’m having a weird issue. My games broke after a Pop_OS! update recently and I’m struggling the most with The Sims 4, I can’t fix it after trying changing some settings, although they were all fine just two days ago: changing the wine version, changing laptop resolution, verifying it’s running on x64 and using the appropiate GPU, because another game I have (Overwatch) also broke down, but I found out the update did a reset on my selected GPU for some reason; had to switch it back from Integrated to Nvidia, delete and reinstall the entire driver as a first time ever for me, but that game works now, not sure why The Sims 4 wouldn’t, it was working well before such update.

To add further context, it opens up windowed and tiny on a corner like shown below, (I can maximize it, but it won’t go in Fullscreen as it used to), and it seems it stays frozen as that, because I tried waiting 30 minutes, clicking on “Wait” a good amount of times just in case, but it used to take up to 5 mins or less to load up before with mods and all. I also deleted the Cache file the game creates for itself and Lutris’ logs show no issues at all, not sure what else to do :frowning:

1 Like