Back to the main site

[SOLVED] TESO - FPS drop

Hey,

I notice FPS drop on lutris for a while. I never really dug to much but it’s currently becoming very annoying as it corrupt my mouse movement, ignoring last part of it.

I recently got a new CG (rx 6700 xt) and installed amdgpu drivers, on debian 11. I m using lutris 0.5.8.4.
I m playing TESO, over tkg-4.2-x86_64 wine version.
There is my lutris issue report : bin.infini

When I ve fps drop, I ve such syslog event :

Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x4a00003
libinput error: client bug: timer event6 debounce short: scheduled expiry is in the past (-1ms), your system is too slow
Window manager warning: last_user_time (61031177) is greater than comparison timestamp (61031176).  This most likely represents a buggy client sending inaccurate timestamps in messages such as _NET_ACTIVE_WINDOW.  Trying to work around...
Window manager warning: W2 appears to be one of the offending windows with a timestamp of 61031177.  Working around...

I focused my searchs about :

libinput error: event6  - Logitech G502 HERO SE: client bug: event processing lagging behind by 104ms, your system is too slow

Or alternatively :

libinput error: client bug: timer event6 debounce short: scheduled expiry is in the past (-1ms), your system is too slow

I had also issue with the keyboard, read somewhere here about accessibility, so I went to parameters > accessibility; then desactivated all items about keyboard and mouse.
It fixed the keyboard lines, but I still having theses lines for the mouse.

I would like to try a more recent tkg wine build, but I m not sure about to build it and link it to lutris.

By the way, is it a libinput issue ? Why wine runner is using xinput instead ? Can I switch the runner to libinput ?

Tryed to install custom wine. Got there is a wine-wayland, that I uncompressed into .local/share/lutris/runners/wine. Wasn’t a great success. Got I could use a custom wine more simply but wanted to put it near other runners.

I tried to compile latest wine-tkg-git from github and got an unexpected result.
1st, I had this compile error :

/usr/bin/ld : dlls/ws2_32/socket.o : dans la fonction « WS_select » :
socket.c:(.text+0x6f47) : référence indéfinie vers « _get_fd_type »
tools/winegcc/winegcc -o programs/dism/dism.exe.so --wine-objdir . -m64 -fPIC -fasynchronous-unwind-tables -mconsole \
  -municode -mno-cygwin programs/dism/dism.o programs/dism/version.res dlls/ucrtbase/libucrtbase.a \
  -Wl,-O1,--sort-common,--as-needed
collect2: error: ld returned 1 exit status
winegcc: /usr/bin/gcc failed
make: *** [Makefile:233189 : dlls/ws2_32/ws2_32.dll.so] Erreur 2

I m not used to compile myself such soft but as bad side effect, about tkg-4.2-x86_64, I was now getting this error :

Jul 17 17:59:49 delu net.lutris.Lutris.desktop[3222]: Unhandled exception: page fault on read access to 0x00000004 in 32-bit code (0x004485eb).

I tryed to change the runner from tkg-4.2-x86_64 to lutris-6.10-7-x86_64, I already tried but I had sound issue on the homepage before. Nevertheless, as good side effect, the sound issue is fixed and it works fine on this wine version.

I still having some lines with “too slow” but there is no more fps drop.

So, I started to run the session on X11 instead wayland, I had less fps drop. Then compiling the latest tkg broke the current tkg runner and fixed the latest lutris runner. Ok, everything is under control…