[SOLVED] Stuck on Install "Select Installation Directory" for Battle.net

Pastebin: Ubuntu Pastebin

I carefully followed all the instructions in the github link and installed the Wine dependencies and the Vulcan drivers for AMD

This is a fresh install of Ubuntu 22.04.2 LTS

lutris -d
2023-04-24 20:57:05,938: Starting Lutris
2023-04-24 20:57:05,975: No cores found
2023-04-24 20:57:06,810: Failed to read content length on response from https:// api .github. com/repos/lutris/dxvk/releases
2023-04-24 20:57:07,377: Failed to read content length on response from https:// api.g ithub. com/repos/lutris/vkd3d/releases
2023-04-24 20:57:07,593: Startup complete
INFO 2023-04-24 20:57:07,595 [startup.check_driver:61]:Running AMD Mesa driver 23.0.3 on AMD Radeon RX 580 Series (polaris10, LLVM 15.0.7, DRM 3.47, 5.19.0-40-generic) (0x67df)
INFO 2023-04-24 20:57:07,595 [startup.check_driver:73]:GPU: 1002:67DF 1462:8A92 (amdgpu drivers)
DEBUG 2023-04-24 20:57:08,206 [lutriswindow.update_store:451]:Showing 0 games

[SOLVED] Don’t use the snap store for installation, just download the .deb from the download tab, right click on the .deb, go to the permissions tab and their should be a check box for Execute, check it, close that window, right click again, have it “Open with other application” and open it with “Software Install”. Easiest way to do it in my experience.

1 Like

See that little piece that says starting Lutris - your lutris version is out of date - follow the download links to get the 0.5.12 Deb for Ubuntu then post again if it fails

Ubuntu provides an outdated Lutris version, install more recent stable version from here:

1 Like

@ legluondunet That did it, very annoying that ubuntu software doesn’t have the updated version.