[Solved] Steam forgets added disk where games are installed


I have a question from the Steam category but I hope I can ask it on this forum.

The problem is that every time I restart the system Steam forgets my second disk where I store all installed games so I have to manually add this location in the Steam setting every time I want to play after turning on my system (Ubuntu).

I would like to ask what should I do to make this second disk installation place permanent in Steam.

Any helpful support would be great :slightly_smiling_face:.

If this is not a place where I can ask questions about Steam I will delete this topic.




I noticed that when I enter my second disk in Nautilus in Ubuntu Steam and Heroic see my installed on this disk games so the problem is only with “activating” this disk on system enter.

Does anyone know how can I achieve that?

That’s correct. You have to mount the partition at startup.
The “correct” way is to edit /etc/fstab, but gnome-disks can do it for you graphically.

I use Linux Mint and have used of the program DISKS (gnome-disk-utility) to fix that exactly problem.
The pictures bellow were made in PtBr by I hope they will look similar on any language.

1 - Open DISKS and select your second disk. Click on that Montage Options section

2 - Unselect the that buttom and choose to mount on System Start

3 - In my experience the default Label identification is a very long series of numbers. I’ve change to SSD to easier my life.

Thank you guys for your help. I have already found the answer on AskUbuntu website:

  1. 13.10 - Steam forgets where game directory is on second HDD - Ask Ubuntu
  2. Is there a program to mount all of my drives automatically? - Ask Ubuntu

From my experience I can add that it is good to give in this mount settings a name disk to Games (if you store in second disk only games) and display name to pick on Label=Games.

Thanks again. Great work :blush:.

1 Like