[Solved] Steam content servers unreachable

I have a strange problem regarding Steam. Every game I try to download generates the following error message: “Steam content servers unreachable”.

I can see my friends list, but no news or games are able to load/start downloading. Am I missing something? This same error is generated when I open Steam through Play on Linux, so I’m suspecting something is wrong with Wine itself.

Thank you in advance.

I had that exact same trouble when I started using Steam/Wine-Steam. It automatically went away after some time (5 minutes). Games started downloading and working correctly afterwards.

After that, I never encountered that problem again, so it feels like some “setup” thing.

Okay, weird.
I’ll give it another try and just wait for a while. I will reply with the results :slight_smile:

So waiting 5 minutes didn’t help. However, installing Wine staging 3.11 seems to have fixed the problem. (I did install that version through Play on Linux though).
What might have fixed the problem is activating 32-bit architecture with: sudo dpkg --add-architecture i386, following the steps here: https://wiki.winehq.org/Ubuntu

Hopefully this might help someone else experiencing the same problem.

Oh, so you didn’t have Wine installed?

I made a previous post here talking about WINE+WINE-Steam hidden dependencies. You do need a system-wide install of wine. I didn’t add that one line to make it work, though.

I simply added the wine repository and then “sudo apt install --install-recommends winehq-staging”