Back to the main site

<SOLVED> Starcraft II not using discrete graphics

Hello, I’ve installed Lutris and Starcraft 2, but starcraft wont use my discrete graphics. When I played on Arch, I had no issues at all, now I’m on Manjaro and I have this issue. I checked my drivers and I think everything should be good. (Ive installed the non-free drivers automatically, manually added, mesa, cuda, wine and all dependencies) (Lutris gives nice warning if you dont have everything you need until you do, so thumbs up for that!!) I’ve checked the boxes for DXVK and use discrete graphics, I’ve tried mutliple WINE versions, reinstalled the game like 3 or 4 times, (also tried the D9VK version but this one doesnt start at all) if I enable either optirun of primus the game wont start either (the battlenet app doesnt even start this way…)
I searched on google and on the forums but cant find a fix.
(I’ve read that some people have the same issue on windows so it could be an issue with blizzard/starcraft itself…)

My system specs:
MSI GF62 8RE
I7 8750H hexacore
Intel UHD 630
Nvidia GTX 1060 6GB
16GB DDR4 RAM
OS: Manjaro Linux x86_64
Kernel: 4.19.59-1 (LTS)
Display res: 1920x1080
WindowManager: I3-gaps (Manjaro community I3 version install out of the box)
current non-free drivers : video-hybrid-intel-nvidia-bumblebee
open-source drivers: video-linux and video-vesa

If you need more info please tell me! I hope someone can help me figure it out!
Kind regards, Kevin.

Problem solved. User was not added to the bumblebee group. (Which should’ve happend automatically I thought) After is added user to bumblebee group, game starts with primus and I can launch starcraft 2 with highest settings without stuttering whatsoever! Leaving the post here so if anybody has the same issue they know how to fix it!

gpasswd -a user bumblebee (to add user)