[Solved] Star Wars: The Old Republic. Launcher stops to download or install


I have a problem with the SWTOR installer. Everything works great in the lutris-installer and i can open the gameclient-launcher. But it stops either to download or installing after some time in the launcher. It’s usually on the “Main Assets 1” or the one after that. It’s random i might edit!

So plz can someone fix this?

I use Ubuntu 16.04.5
And are using the latest AMD-drivers for my Radeon R9 290

Are you sure it’s stuck and not just taking a long time? Enable output debugging info under Runner options, close Lutris, run it via terminal lutris -d, launch SWTOR, and post the terminal output here.

Here’s the terminal output: https://pastebin.com/q8C1csVr

I stopped the gameclient in the end of this pastebin.

This is from the Lutris: Last game’s log:

wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
[0916/182919:ERROR:network_change_notifier_win.cc(111)] WSALookupServiceBegin failed with: 8
[0916/182919:ERROR:proxy_config_service_win.cc(159)] WinHttpGetIEProxyConfigForCurrentUser failed: 2
[0916/182930:ERROR:proxy_config_service_win.cc(159)] WinHttpGetIEProxyConfigForCurrentUser failed: 2

I might add that the winemenubuilder fails to install in the Lutris-script and then just skips it.

That isn’t the problem. This is:

0009:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0009:err:module:import_dll Library avutil-51.dll (which is needed by L"C:\\Program Files (x86)\\Electronic Arts\\BioWare\\Star Wars - The Old Republic\\avcodec-53.dll") not found

Please install Wine to your PC. This is needed for dependencies that Lutris doesn’t provide.


Open a terminal and do these one at a time:

sudo dpkg --add-architecture i386 

wget -nc https://dl.winehq.org/wine-builds/Release.key

sudo apt-key add Release.key

sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/

sudo apt-get update

sudo apt-get install --install-recommends winehq-staging

I got winehq-devel installed already… So Staging is better then?

And do i need to run Lutris again or just wine it on my own from the pc?

Did you install with --install-recommends?

Yes but i’m gonna re-install it and go with staging brb

Do i need to boot the game from terminal like: wine launcher.exe Or run it in Lutris?
Or copying files to the installed directory?

Still the same problem…

avcodec-53.dll and avutil-51.dll is in the gamefolder…
installed samba and winbind too but that didn’t work either.

I changed wine-build to Staging-3.8 and now it works! So problem solved! :slight_smile:

1 Like