Back to the main site

[SOLVED] Sims 4 [Origin] - Game Won't Launch


#1

Hello,
So after my previous post about not being able to access the wine configuration in Origin, I managed to get that fixed but now I have a different problem. I installed 64 bit Origin via the script on this site (the one marked gold here) and downloaded/installed all of the Sims 4 content I have (which is all of it) but when I try to launch the game it doesn’t do anything. Origin blinks (like its going to minimize to the taskbar for the game to launch) but nothing happens. I tried launching Lutris from the terminal to see what was going on, and I can supply that output, but honestly nothing comes up after launching Origin. I mean, nothing is added to the output when I try to launch the game itself.
I know there is also an install script specifically for Sims 4 but its for the DVD verison which I don’t have.


#2

Try disabling Origin In-Game? RIght-click Sims > Game Properties > Enable Origin In-Game


#3

Disabling Origin In-Game for Sims specifically worked insofar as I’m actually getting an error coming up in the terminal output. I had the in-game disabled overall so I don’t know why it was still enabled on sims.
Anyway, it’s now saying

Unimplemented function msvcr120.dll._get_purecall_handler called at address 0x7b450197 (thread 00f0), starting debugger…

I did a little searching and found a bug from November that caused the same error due to needing vcrun2013 added but not only has that been marked resolved on bugzilla, but I have 2013 installed already and 2012.


#4

I just took out both vcrun 2012 and 2013 and reinstalled them and its working now. Launched and everything.


#5

Hi,

I’m trying to play sims4 after install gold script. Everything was going fine till I try to open the game from origin under lutris.

It comes out “The program TS4_x64.exe has encountered a serious problem and need to close…”

Please suggest!!


#6

Have you tried the stuff above? Disabling origin in-game, removing all the installed vcruns using winetricks and then adding 2012 and 2013 back in?