[SOLVED] SHA256 error with times32.exe (Trying to install EA app)

Hi there!

With the apparent revival of Titanfall 2, I’m trying to install EA app on lutris, but every time I try to install it, it crashes when it tries to download the file times32.exe, quoting a SHA256 mismatch, halting the installer with code 256.

How can this be fixed? I have already tried deleting the ~/.wine folder and downloaded the corefonts separately, with no results.

Here’s the ending portion of the installer log.

Plus: lutris-issue-report.json

Thanks in advance!

I have already tried downloading corefonts separetely to ~/.cache/winetricks/corefonts (Lutris from DNF), but the exact same error still happens.

I was experiencing the same issue trying to install the Epic Game Store / Ubisoft launchers. I downloaded all the fonts from the link provided by jhu and replaced all the fonts in my winetricks/corefonts folder. Tried again after doing so and the install completed successfully. I downloaded and replaced all the fonts because after replacing just times32.exe and trying I saw that the next time it failed it was due to a different font, so I just replaced them all.

You have to delete what is already in the corefonts folder first - the issue is corrupt or 0 byte files coming over where a simple replace doesn’t seem to work.
Also, if the problem persists, close lutris (reboot even) and then launch lutris in terminal with lutris -d, run the install and if it fails read the pinned message in the forums to get the debug output (or head to the lutris discord server)

That did the trick!
Here’s what I had wrong: Since I installed from DNF, I supposed the folder was the one I mentioned in my original reply, even if it didn’t exist, but the correct one was under the .var folder, so now it installs properly.

PS: It doesn’t work changing just one file, it HAS to be the whole bunch.