(SOLVED) Rockstar Launcher either no audio or no internet connection


With Rockstar Launcher, it will work, with:

Disable Lutris Runtime: OFF

Prefer system libraries: OFF

This will run fine and be online, but then there’s no audio? I have tried with both Flatpak Lutris and .deb version of Lutris and the .deb version of Lutris, with exactly the same results.

Using the most recent version of GE-Proton8-13 and Lutris-GE-Proton -14x86_64, both with the same exact results.

I have added all the ports listed on the Rockstar website listed for Rockstar Launcher to my firewall, that doesn’t work either.

Ubuntu 22.04LTS, Low Latency Kernel HWE, Pipe Wire Audio

Anyone having the same problems? Anyone have a fix?

Re installed it all, seems there was a Rockstar Games Launcher update, and now it works, even adding it to steam, and even with steam-presence for Discord and changing in the icon for it if you name it ‘Grand Theft Auto V’ and follow the instructions in steam-presence instructions on GitHub, you can use a custom icon on Discord, FYI.