Back to the main site

[Solved] Permission is denied when I try to launch a game

The game is actually Google Chrome portable for Windows downloaded from the following page:

I have downloaded the following version:
GoogleChromePortable64_97.0.4692.99_online.paf.exe

If you want to know why I have to use Google Chrome for Windows instead of Google Chrome for Linux, see the following post:

After starting Lutris without “sudo”, when I click on “Play” to launch Chrome, I will see the following error message:

https://forums.lutris.net/uploads/default/original/2X/1/16330ac8d4a623b79be6ff1501f7b9e917ac549e.jpeg

Is it possible to launch Chrome without “sudo”?

1 Like

I see. That is really curious but it makes sense now.

Again, Lutris should not run with superuser privileges. At least, I’ve never needed to do so.

Let’s gather some logs for a start:

  1. Close-and-open Lutris to clear its old logs
  2. Try to start your Chome
  3. After it crashes, close the error window and save logs:
    Right click upon your Chrome icon → Show logs → Save it to a local file
  4. Post the log file there.
1 Like

This morning, I uninstalled Lutris, reinstalled it, and added the game “Chrome 97”. When I clicked on the “Play” button, I saw the following error:

Then, I ran the following command to fix the error:

sudo mkdir "/opt/apps/net.lutris.lutris/files/games/lutris-wrapper/"

Then, I clicked on “Play” again, and I saw the following error:

Permission denied

I closed the error message and right-clicked on “Chrome 97”. The item “Show logs” was greyed out as shown below:

My bad, I did not ask you earlier…

What OS do you use?
What way did you install Lutris?

It seems to me that Lutris is installed not via a packet manager but from sources or something like.

Also, you can try just change owhership for the Lutris dir (given that your user is Matthew_Wai):
chown -R Matthew_Wai:Matthew_Wai /opt/apps/net.lutris.lutris

I use UnionTech OS Desktop Home.
I ran the following command to download the Debian packages for Lutris.
sudo apt-get --download-only install net.lutris.lutris

I have run your “chown -R” command but still see the same error message.

Seems that it has a different directory structure rather than standard DEB distros. Doesn’t make the task any easier…

Okay, let’s try another approach:
Just run lutris from the command line, try to run Chrome and post there whatever it prints to console.

I’m not familiar with the UnionTech peculiarities bit it is probably may be enough to install package execute sudo apt install net.lutris.lutris or sudo apt-get install net.lutris.lutris

I ran “lutris” from Terminal and got the following:

Command not found

Your above command will download the packages and install them automatically.
The following command will download the same packages but not install them.

sudo apt-get --download-only install net.lutris.lutris

I manually installed them after downloading them.

I beg you, next time just copy a text instead of screening it. It is annoying, it really is.

Okay, that is gradually becoming even more interesting. let’s use a one-size-fits-all solution to find the lutris executable:
sudo find / -name lutris

I know. I just wondered why do you need to hoard them.

1 Like

I have not run your command, but I found the following file:
/opt/apps/net.lutris.lutris/files/bin/lutris
I ran it, selected “Chrome 97”, and clicked on “Play”. Then, Chrome was started successfully. I have created a desktop shortcut to it.

Ironically, if I click on “Lutris” on the application menu and try to play “Chrome 97”, “Permission denied” will be displayed.

Thank you very much for pointing out the following:

I did not realize “sudo” should not be used.

Reason: I need not download them again when I install Lutris next time.

Well… I’m really happy that you were able to make it work! :smiley:
Still, I have no idea what happened there and what could be done to prevent it from happening again and what the right way to fix it. It is kinda perplexing.

Hmm… I’d prefer to conserve my HDD free space rather that my traffic. But is up to you, of course. Just want point out that apt has its own caching mechanism. It stores packages in /var/cache/apt automatically. At least, Ubuntu does. What about yours OS, i’m afraid to guess.

Cheers!

1 Like

Silly question: Instead of going through all this, have you tried using a user-agent switcher addon for Chrome? If the website is only checking the browser header, it may solve your problem without needing to install the Windows version of Chrome.

I don’t use Chrome personally, but maybe something like User-Agent Switcher for Chrome - Chrome Web Store

1 Like

Early this month, after using such an add-on, I got the result described in the following post:

Did you actually use the addon and change the user-agent? I use Firefox, but when I change my user-agent and visit whatismybrowser.com, it tells me I’m using the browser I’ve selected from the addon:

image

I’m on Linux by the way, not Windows :slight_smile:

You do need to open the user-agent switcher and choose the browser you want the site to see:

1 Like

I just installed Firefox and added “User-Agent Switcher”, which actually works! I can’t thank you enough!

Switcher works

I actually did it on Chrome but never did so on Firefox until I read your suggestion today. Evidently, such an add-on works better on Firefox.

1 Like