Back to the main site

[Solved] Path of Exile [Steam] - Manjaro


#1

Hello all,

4.14.12-1-MANJARO - XFCE - Using Wine-Staging 2.21

Using the Lutris installer for Path of Exile is not working. Steam installs and tries to load it and it quits right away.

After going through the install script and double checking the tasks, it did not create the wine reg entry for VideoMemorySize.

When checking what dlls are installed in winetricks, I don’t see riched20 or usp10 installed. When trying to install them, they just are stuck on running.

I also tried disabling GLSL which seems to come up on forums if you do some web searching.

Does anyone have it working?

Thank you,
Zavo


#2

I had the exact same issue on Arch Linux.
After some Troubleshootings, I managed to get it running by using another Wine-Prefix.
I dont remember why but I switched over to the Standalone version of this game. It works flawlesly with my Steamaccount data.
I would recommend you to test the standalone version aswell or just switch the prefix to another with all dependencies installed. I think D3D9_42 and vcrun2008 is enough to get it running. I addes in the “Gameoptions Tab” the Arguments: --waitforpreload --nologo --noasync

Hope this will help you. Sorry for my bad english :>


#3

Ah.

Anyways normal way to look whats the matter, is to switch on terminal output. This will give you some hints on whats wrom exaclty.


#4

Hey Fladie!

I appreciate the feedback. I tried for an hour to get it working with the standalone version and the steam version with different wine-prefix but no luck.

I’m not that skilled at playing around with wine/winetricks/lutris/configs

For the debugging, I turned it on to full but don’t know where the logs go
Also, where you say “switch on teminal ouput” I’m hoping that means “run in terminal” and when I run wine pathofexile.exe from the terminal, I get some errors about missing .dlls.

Thank you for your time. I’ll keep plugging away at it.


#5

@Zavoka The Steam version is working for me except pathofexilesteam.exe hangs for a few seconds until it proceeds to the login page. Do you have Wine installed on your system? If not follow this: https://www.gloriouseggroll.tv/how-to-get-out-of-wine-dependency-hell/


#6

Thank you @cxf

installing all the additional wine items from your link has allowed me to get PoE running using the steam version.

Woohoo!