[Solved][partially]Battle.net won't start anymore

Hello there.

I am having a hard time, I installed World of Warcraft using Lutris 3 days ago, all went well.
Today I could not start either Battle,net app nor Wow.exe.

I didn’t update anything and unless the settings for another (steam) game apply for all titles under Lutris, I didn’t change any configurations either. It just no longer runs.

Exact description:

Battle.net: Starts, but once automatic login go through, battle net won’t open. It crashes with unexpected error from Blizzard. Tried to run with proton, wine, Lutris 5.5 and crash appearance differ slightly but eventually the same thing.

Wow.exe: Changed executable from Battle.net.exe to Wow.exe inside lutris configuration and tried to run it.
Black screen with Error window appear saying World of Warcraft was unable to fire up 3D acceleration. Running Wow.exe without DXVK works fine but performance is nowhere to be playable (didnt even enter the world, lack of performance is too obvious)

Please, find screenshots of a problem, and output of lutris --sumbit-issue and lutris -d here:

I appreciate any help as I have very little time for games and would like to run it smoothly so I can enjoy my gaming time.
Please, try to explain steps if you think you could help. I am still not very experienced.
Stay well and thank you!

EDIT: Apparently, Battle,net works without DXVK. I disabled in configuration and Battle,net works now. Only the actual game is poor performance. Whenever I enable DXVK, Battle net won’t work and running wow.exe directly throws error about not being able to start up 3D acceleration (see above “exact description”)


I switched to opensource nvidia driver and it works fine now.
Not sure why, I was playing on proprietary driver and it suddenly stopped working.

Anyway, it works now.
Screenshot of a current driver in use, along with propriertary one