[Solved] Overwatch - Ubuntu Mate 18.04 - R9 290x

I’m having some issues getting Overwatch to run. Tried both install scripts via the games page, changing WINE to multiple different versions, adding the msvcp140 and vcruntime140 overrides, DXVK on, DXVK off, etc. No matter what I do though, it just sits there at ‘Playing Overwatch’ but the battle.net launcher never opens. Pretty sure everything is up to date. ‘glxinfo | grep version’ pulls up:

Max core profile version: 4.5
Max compat profile version: 3.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1

OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.1.5 - padoka PPA
OpenGL core profile shading language version string: 4.50
OpenGL version string: 3.1 Mesa 18.1.5 - padoka PPA
OpenGL shading language version string: 1.40
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.5 - padoka PPA
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

It installs just fine, and I’ve double checked to make sure I have all the dependencies installed, and I’m using the AMDGPU kernel as well, but I’m clearly missing something. Anyone have any ideas?

Welp, tried lol-3.13 and it worked right away. Using DXVK .54 . Still fidgeting with the settings a bit, seems to get choppy when other players are loading in, but hey, at least its running now.