[Solved] Overwatch Crashes Immediately After Picking Character

Game installs, loads fine (keyboard doesn’t work unless I change to borderless window), FPS looks fine.
Try to join any game (online or training) it crashes after picking a character (I’m able to look around for about 0.5 seconds)

Vega 64
DXVK .70
Mesa 18.3.0
LLVM 8.0.0
Wine esync-3.14
(I’ve also had this exact issue on older versions of all the above, It’s never worked for me)

Solved: DXVK 0.63 or less, breaks with 0.64+
Releases after 0.70 should work. Fixed with https://github.com/doitsujin/dxvk/commit/09948a3495c6a389fdd5ef87369b78bee72eef7d

AMD related, probably with LLVM. Take it to DXVK discord, they know that stuff.

After more investigating, seems to be something in the Lutris script.

Starting it via cli:
~/.local/share/lutris/runners/wine/esync-3.14-x86_64/bin/wine ~/Games/battlenet/drive_c/Program\ Files\ (x86)/Battle.net/Battle.net.exe

The issue no longer exists. I’ll have to mess around to find the exact issue.

  1. What distro are you on? Try disabling runtime, it is Ubuntu based, so it could conflict.
  2. Did you check wine log for the crash?
  3. Howmuch VRAM do you have on that Vega?
  4. Did you disable PBA as instructed?
  1. The script enables mesa_glthread for AMD in ENV variables, try turning that off. Perhaps something in Vega cannot handle that.

And you had AMD? And you had the same issues?

Just for the record: setting PBA to disable when you use DXVK is what is advised on every Blizzard installer page.

EDIT: Was responding to someone that deleted his / her post it seems.

Sorry, I thought that was what caused it but it appears it was a red herring.

Original comment:

I set PBA_DISABLE to 1 in System options when Configuring Overwatch in Lutris, no more crashes to desktop appeared after that.

Had to reinstall overwatch as I was running into connection errors:

After that the crash to desktop started on first AI match, tried training match, same result.
Tried again and it no longer crashed in training match and following AI match.

Ran Lutris from terminal with lutris -d, nothing useful showed up besides game thread stopped.

It can give issues, which is why I suggest to people to turn it off when using DXVK. (Though only issue I have heard about is a person with low VRAM and blizzard app, not a game itself).

Like said above, the only thing I have heard about is that certain versions of LLVM had issues with Overwatch. A fix is out, but I don’t know in which branches those fixes are. I don’t have AMD.

Ah sorry forgot to answer that, yes I have an RX 56, using amdgpu.

  1. Fedora 28. What do you mean?
  2. Lutris -d only gives “AL lib: (EE) ReleaseThreadCtx: Context 0x7fd3c800c570 current for thread being destroyed, possible leak!”
  3. 8GB of VRAM
  4. Yes
  5. No difference

I noticed all the hair shaders are bugged when launching through Lutris.

I have Dota 2 (native) crashing on character select screen under Vulkan API, probably because of shaders loading in.

The lead that LLVM might be culprit should be looked into. Maybe LLVM 8 “is too much”. Can you people run dota 2 native on vulkan? (plus the free DLC vulkan support)

Are you on LLVM 8? If you downgrade to 7 or 6, do things still crash?

I’ve tried LLVM 8, 7, and 6. Same result. But I don’t think my issue is strictly LLVM, because my problem is resolved if running Battle.net directly using the wine runner.

When you run directly using the Wine Runner, does it also use DXVK? (please put env DXVK_HUD=1 before your command to check)

I’m just making sure Vulkan is taking part in this whole process (in some way)

EDIT: I had a case where Path of Exile would run with regular wine, but not with DXVK enabled…

Wow, I feel dumb, Yea DXVK wasn’t running. I just kinda assumed it was since it was pretty smooth at Ultra, guess I just don’t need DXVK?

Right…take it to DXVK github with your issue if it is with DXVK. And then please mark this thread as solved.

Seems 0.62 should work without issues. So if someone with AMD could help bisect it.

Update: 0.71 should fix it.